dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: Strange CPU usage caused by some Flashkit pages

  1. #1
    Stupid Little Dreamer
    Join Date
    Aug 2000
    Location
    Toronto
    Posts
    583
    I run Win2000 on a P-III 866 machine, and have discovered that after posting a reply and waiting for the page to refresh (ie with my reply now showing up in the forum), my machine gets really clunky. Through Win2000's Task Manager, I see my CPU usage is pushing 100%. So I close the Netscape window that had the Flashkit page, and that solves the problem. (Netscape is still running in a couple other windows.) Normally I'd only have to press ESC to stop the page loading, but that has no effect.

    I don't know enough about javaScript and the your embedded links to begin to guess at what might be causing this, but I thought I'd point it out.

  2. #2
    Senior Member
    Join Date
    Nov 2000
    Posts
    302

    It's the alpha layers

    If people use a duplicating movie with many alpha layers e.g. transparencies then it eat's CPU power.
    have a look at this smoke effect i did, look at your CPU power when running it

    http://www.flashkit.com/movies/Anima...06/index.shtml

    It's just a really CPU intensive operation to perform...

  3. #3
    Stupid Little Dreamer
    Join Date
    Aug 2000
    Location
    Toronto
    Posts
    583
    Yeah, I finally realized it was just coming from people's footers--mine included! It took me awhile to figure this out because every page has a different collection of footers, and some are easier on the CPU, so I'd mistakenly ruled footers out as the cause. Now I know better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center