dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: massive sound.start(7,0) offset bug!

  1. #1
    Senior Member
    Join Date
    Aug 2000
    Posts
    264
    Has anyone noticed that on setting an offset value to the start() method eg
    Code:
    mySound.start(7,0);
    of a long 10 seconds + sound length, the sound fails to play all the way through to the end when you use a high offset!

    Eg try the following code with a sound of around 10-20 seconds in length:

    On _root
    Code:
    mySound=new Sound(this);
    mySound.attachSound("soundtoAttach");
    Code:
    //on button 1
    _root.mysound.start(0,0);
    
    //on button 2
    _root.mysound.start(3,0);
    
    //on button 3
    _root.mysound.start(8,0);
    //on button 4
    _root.mysound.start(10,0);
    I think this is a bug as it gets the offset correct and plays the sound, but fails to reach the end!
    Cheers

    Sam

  2. #2
    Junior Member
    Join Date
    Aug 2000
    Posts
    28

    sound offset

    hey,

    i noticed the same thing. did you figure out any kind of
    solution? please let me know if you do and i will do the same if i find a way to make it work.

    i work on a mac and have noticed a few bugs in flash 5. frustrating.

  3. #3
    Senior Member
    Join Date
    Aug 2000
    Posts
    264
    Apparently it's a limitation / bug of MP3 in Flash5??

    Use ADPCM compression format instead and it should work fine!


    Sam

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center