dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: <

  1. #1
    Senior Member
    Join Date
    Aug 2001
    Posts
    280
    i have 5 scenes or so in my movie and i have the buttons for each of them. Now on the stage i right clikc on the button and add the script on release gotoand play then i put in my scene Home and put frame 2. but when i play the movie and click the home button it just replays the menu loading action and the rest doesnt restart. And when i add the script for the info section and when i click on it, it should bring me to a blank scene but it does nothing except replay the menu loading action. WHY?!


    thanks for any help

    nigel

  2. #2
    Member
    Join Date
    Aug 2000
    Posts
    83
    Try using labels when you have more than one scene

    place a label whereever you want your buttons to go

    then have this code in your button

    on (release) {
    _root.gotoAndPlay("labelname")
    }

    labelname being the label of the frame where you want that button to go

    Regards...

  3. #3
    Senior Member
    Join Date
    Aug 2001
    Posts
    280

    hiu

    no i have that, i have the scene and frame specified. It should work but i odnt know why it doesnt

  4. #4
    Member
    Join Date
    Aug 2000
    Posts
    83

    Re: hiu

    flash does not always work fine with frames when you have many scenes...if we use labels it works fine without any problem

    this is because flash takes frame numbers continuously when there are many scenes

    eg: you have two scenes and 10 frames in each scene
    flash takes it as 20 frames altogether instead of 10 frames in scene one and 10 frames in scene 2

    If you open the bandwidth profiler and see the frame number you will be able to understand better.

    Regards...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center