dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: Can someone HELP please

  1. #1
    Junior Member
    Join Date
    Aug 2000
    Posts
    24
    i created a movie and also a preloader (a simple one with just the text LOADING...). How do I make the preloader loop? When the movie plays the LOADING... text comes up and then disappears and then my movie starts but is not completely loaded (which is why i need the preloader right? to load the movie). WHat am I doing wrong? Can someone take a look at it? If I send my fla file to someone can they please take a look at it and see what I have done wrong. I'm trying really hard to learn flash 4 and just when I think I'm making progress, something just doesn't work right :-(. Any help would be greatly appreciated!

    http://www.bubcowebdesign.com/fdny.html
    (my movie that I am just trying to learn flash with)

    bubcowebdesign@aol.com

  2. #2
    Senior Member
    Join Date
    Jul 2001
    Posts
    505
    create a new scene, add your loading graphic on layer 1 and ad 2 new frames. Create a new layer and call it actions, insert a keyframe on frame 2 and 3 of this layer, now on frame 2 insert this code:

    ifFrameLoaded ("Scene 1", 1) {
    gotoAndPlay (4);
    }

    Change the scene and frame numbers to the last frame of the last scene in your movie, change the "4" to the first frame of your main movie (after the preloader). Now on frame 3 insert this code:

    gotoAndPlay (1);


    and your done, if you can't get it to work, you can email me the .fla file at Amalinde@hotmail.com and i'll take a look.

  3. #3
    Senior Member
    Join Date
    Jul 2001
    Posts
    505
    PS. make sure that the new scene you make for your preloader is the very top one in the scene inspector....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center