dcsimg
A Flash Developer Resource Site

Results 1 to 19 of 19

Thread: Events in actions?

  1. #1
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244

    Post

    Rob and team mofosoft,

    Will there ever be the ability to have an event within an action?

    Seems a natural step. Saves having to make a child movie for everything which is what I now do.

    For example when you mouseover a button, you cannot trigger an event like wave element without putting it into a child movie and using stop and start frames.


  2. #2
    Senior Member
    Join Date
    Jul 2001
    Posts
    116
    3DFA is limited by what the flash file format can do. Events in actions are not essential because you can work around them with child movies.

    If we were to incorporate them then we would do it by providing a simple hidden interface to event child movies. At some time in the future, we may offer that kind of functionality.

  3. #3
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244

    percent fix

    Originally posted by a_non_amous
    Rob,

    I don't mind using child movies I actually use them all the time.

    The thing that annoys me is when I import an already created movie into another movie I then have to go and reapply all of the links in the imported movie.

    I tried to get the loading percent thing to work but am having no luck.

    Could you possible send me a sample that works.

    Regards,
    a_non_amous.
    Anon,

    Go into the list of actions and fix the broken links.
    where the first is show p10, show p20 etc.....

    That'll do it.

  4. #4
    Senior Member
    Join Date
    Jul 2001
    Posts
    116
    I dont get it with the broken links thing. You start a new movie - in the loading movie option - you choose the progress bar - you open the actions element - and all of the links are correct - p10, p20, p30 ...

    If this isnt what you guys are seeing then something strange is happening - and the sooner we get to the bottom of it, the better.

  5. #5
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244

    I believe you

    Originally posted by RobStewart
    I dont get it with the broken links thing. You start a new movie - in the loading movie option - you choose the progress bar - you open the actions element - and all of the links are correct - p10, p20, p30 ...

    If this isnt what you guys are seeing then something strange is happening - and the sooner we get to the bottom of it, the better.
    Robert, that is definately NOT what I saw. When I loaded the movie in it didn't work, so I clicked on the element button (or whatever you call it) then looked in the list of actions and all of the links to p10 etc where listed as Broken link.

    Like I said easy to fix,but broken.

    Same thing happens all the time if I load a movie in as a child movie.

    nearly all the links break.

  6. #6
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244

    correction

    Sorry Should have said that this happened ONLY the first time I loaded the percent movie.

    Since I fixed it, it loads fine into parent movie.

    However I still have this problem with loaded child movies.


  7. #7
    Senior Member
    Join Date
    Sep 2001
    Posts
    161

    Only an example

    Originally posted by a_non_amous
    Rob,

    I don't mind using child movies I actually use them all the time.

    The thing that annoys me is when I import an already created movie into another movie I then have to go and reapply all of the links in the imported movie.

    I tried to get the loading percent thing to work but am having no luck.

    Could you possible send me a sample that works.

    Regards,
    a_non_amous.
    Hi! a-non_amous
    This it is an example of a Loading Movie, with percentage. Please tell me if it works in his browser and I place it for download. worked in my site.
    http://www.josephbrowndesigns.com/3dflash/face.html

    Place a movie with greater duration, to see better the action of loading movie.
    It is possible that the previous very fast loading by its short duration
    http://www.josephbrowndesigns.com/3d...or-intro3.html

    Joseph
    [Edited by MrJoseph on 11-16-2001 at 04:10 PM]

  8. #8
    Senior Member
    Join Date
    Sep 2001
    Posts
    161
    Originally posted by a_non_amous
    Hi,

    Here is my finished flash file with a loading percent attached.

    When I view it -- it reaches 2% and never goes higher.

    Can you all give me some feedback please as I am testing my browser.

    Regards,
    a_non_amous.
    Hi!
    Please edit your Link

  9. #9
    Sorry...

    The link =
    http://members.optusnet.com.au/~free...est/test4.html

    Regards,
    a_non_amous.

  10. #10
    Senior Member
    Join Date
    Sep 2001
    Posts
    161

    resolved Possibility

    Originally posted by a_non_amous
    Sorry...

    The link =
    http://members.optusnet.com.au/~free...est/test4.html

    Regards,
    a_non_amous.
    Possibility.
    Its possible that you have broken links check it
    Check syntax at the variable's name between edit box and List of Actions at loading movie.
    Check syntax of mathematics expressions

    Its possible that his loading movie is finalizing by some instruction, or because the duration is very short.
    is only a supposition.

    My settings For loading Movie inside of Main Movie
    Main Window - Elements
    Time=10 sec
    Stop The movie wen finished
    -Edit Box
    Asign to variable Perc
    to Activate icon Element has propierties

    -List of Actions
    Run 10 times per second = on
    Use the parent movie variables = on
    To activate show at the start of the movie
    Let Perc=Round(FramesLoaded / TotalFrames*100)

    Keyframes= 1
    Events none
    Actions for the Keyframe
    Let Perc=0

    Main Movie
    Loading Movie option = play while the entire movie loads


    That's all.

    I hope that this help you in something

  11. #11
    joseph,

    Thanks for the help....

    But I think the problem is that FramesLoaded does not pick up frames loaded from child movies.

    most of my projects use the following format.

    The parent movie contains looping sound if required
    and 1 or more child movies with the animations, buttons effects etc.....

    I created a new simple sample with:
    1. a parent movie.
    2. a contained child movie with a 3d text effect.
    3. a loading percent for the parent movie.

    The percent only shows to 2%

    If you send me your email address I will send you the movie file and you can take a look.

    my email = freeflash@optusnet.com.au

    Regards,
    a_non_amous.



  12. #12
    Senior Member
    Join Date
    Sep 2001
    Posts
    161

    Smile

    Originally posted by a_non_amous
    joseph,

    Thanks for the help....

    But I think the problem is that FramesLoaded does not pick up frames loaded from child movies.

    most of my projects use the following format.

    The parent movie contains looping sound if required
    and 1 or more child movies with the animations, buttons effects etc.....

    I created a new simple sample with:
    1. a parent movie.
    2. a contained child movie with a 3d text effect.
    3. a loading percent for the parent movie.

    The percent only shows to 2%

    If you send me your email address I will send you the movie file and you can take a look.

    my email = freeflash@optusnet.com.au

    Regards,
    a_non_amous.


    Hello
    It seems that already I discovered the problem,
    I only want to be safe before doing nobody commentary.

    Please tell me if the percentage of the example works correctly.
    http://www.josephbrowndesigns.com/3dflash/test5.html
    Joseph

  13. #13
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244

    interesting

    Originally posted by MrJoseph
    Hello
    It seems that already I discovered the problem,
    I only want to be safe before doing nobody commentary.

    Please tell me if the percentage of the example works correctly.
    http://www.josephbrowndesigns.com/3dflash/test5.html
    Joseph[/B]
    Interesting, The percent stayed at 0 while your counter ran up to about 50 the restarted and ran to about 60 then again to about 70 at that point the percentage suddenly showed 71% then the animation started.

  14. #14
    Senior Member
    Join Date
    Sep 2001
    Posts
    161

    Wink It worked but with lack of logic

    Hi Bret and A_non A_mous

    The Example of A_non _ Amous, contains:
    Main Movie Child Movie and Loading Movie, each one of them with its respective times.

    The counter only determines the times that it is executed the list of actions
    inside of loading movie, finally 7200 times at the rate of 10 times per second (720x10)

    What I did was a madness, initiate to play with the times of each one of the movies .

    Thus: Original Example
    Main Movie 10 sec, Child Movie 10 sec, and Loading Movie 10 sec, Percentage=0 or 2% without changes while it loaded

    Variations
    Main Movie 10 sec, Child Movie 4 sec, and Loading Movie 10 sec, Percentage=14% -changed
    (because the effect of the text 3d at child movie only delays 4 sec).
    Main Movie 180 sec, Child Movie 4 sec, and Loading Movie 10 sec. Percentage=38%-changed
    Main Movie 360 sec, Child Movie 4 sec, and Loading Movie 10 sec, Percentage=55%-changed
    Main Movie 720 sec, child movie 4 sec, and Loading Movie 10 sec. Percentage=98%-changed
    and the movie was executed.

    In this example

    If the Time of the Loading movie is varied to a smaller value the percentage does not change. (I think that it loses the value of the variables or these are reinitiated
    )???

    Child movie must have the exact time, neither a second plus nor a second minus.

    The time of the Main movie or parent movie must be the sufficiently ample so that it isn't reinitiated and it allows to execute child movie and of course the Loading movie.

    This can demonstrate that loading movie it is taking the frames value from Parent movie.
    Another thing, when it places counter, worked better the change of percentage ??????
    The question is: Which will be the relation adapted between each one of the times of the movies?.
    Really this is interesting, here can be the key, of some activities that aren't executed in browser, such as Morph and move event, within child movies or call actions.

    It also influences the speed of transmission, I suppose, you obtained 71% and the movie was executed and I 98%.

    I hope that to a_nom a_nomus to him it works

    That You think Bret, I would like much to have his opinion and the one of Rob.

    Thanks!


  15. #15
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244

    Re: It worked but with lack of logic

    BANG!!!

    That's the sound of my head exploding. Joeseph, You lost me man....... Basically it doesn't work as expected. Sigh!

    I think removing unneeded frames and speading content over frames will result in "most" accurate load feedback.

    I may not use this function, I know it must be doable I see it all the time in FLASH on the web but Alas not to be in 3dfa, but you know what it is the smallest of my worries.

    Peace

  16. #16
    Senior Member
    Join Date
    Sep 2001
    Posts
    161

    Re: Re: It worked but with lack of logic

    Originally posted by blanius
    BANG!!!

    That's the sound of my head exploding. Joeseph, You lost me man....... Basically it doesn't work as expected. Sigh!

    I think removing unneeded frames and speading content over frames will result in "most" accurate load feedback.

    I may not use this function, I know it must be doable I see it all the time in FLASH on the web but Alas not to be in 3dfa, but you know what it is the smallest of my worries.

    Peace
    Sorry.. Bret!
    Yes I Know, For my also worked as less it hoped.
    Parent Movie, Child Movie and Loading Movie, Big Problem
    Which will be the best way so that they can work without problems?
    Thanks!
    Joseph

  17. #17
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244

    Re: Re: Re: It worked but with lack of logic

    Originally posted by MrJoseph
    Sorry.. Bret!
    Yes I Know, For my also worked as less it hoped.
    Parent Movie, Child Movie and Loading Movie, Big Problem
    Which will be the best way so that they can work without problems?
    Thanks!
    Joseph
    Actually the only big problems I have left are Move events matching on export, and 3ds import. I really like using Anim8or but 3dFA doesn't like to import the 3ds files it makes. The other bugs are all minor to me.


  18. #18
    Hi,

    Re: percent loaders....

    I have decided until this problem is fixed I will be doing the following for loading percent creation.

    Divide the total size of the flash movie by 5 (approx number of k's for a slow download).

    This will then equal the number of seconds before download completes approximately.

    I will then add the following code to my loading movie.
    let var percentage = percentage + (seconds passed/total seconds * 100)

    on a slow download it will look almost correct.
    on a fast download it will start at a low percentage number but I am sure that no-one will complain.

    I going to wander off and test it now.

    Ragards,
    a_non_amous.

  19. #19
    Ok.....

    The code I wrote in the previous message was rubish.
    but to see my finished test.

    http://members.optusnet.com.au/~free...est/test5.html

    it currently gets to about 91% before loading for me on my slow connection.

    I might improve on it later.

    code looks something like this....

    loading movie is not looping
    action runs 10 times a second
    let aa = aa + 1 //this is a counter
    bb = Round (((aa/10)/19)*100) //19=(swf size/6) approx
    if bb > 100 //stops percent at 100
    let bb = 100
    end
    let percentage = bb //show percentage

    If you have any better ideas let me know.

    Regards,
    a_non_amous.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center