A Flash Developer Resource Site

Results 1 to 2 of 2

Thread: Loading.....

  1. #1
    Junior Member
    Join Date
    Jan 2002
    Posts
    4
    Brand new to flash here and I've got 2 questions...how do you get (or make) a sign that says "Loading..." while you're movie is loading?

    And I'm uploading my flash to my site...it's just a simple nav with some sound, and the first time I uploaded it it was fine, then I changed some sounds and uploaded again and half of the sounds went away (when I actually doubled the sound effects), and changed it back to the way it was originally, and now it's completely gone, and no matter how many times I upload it and tweek it around it won't show up any more. I did "test movie" "test scene" and "debug movie", and it all shows up fine there...I double checked my HTML and "Publish Settings" and they all look fine...any ideas???

    http://www.pmvclan.com/pmv.htm

  2. #2
    Junior Member
    Join Date
    Jan 2002
    Posts
    17

    about the loading

    Those things are called preloaders.You have to put them in the movie at the very first frames.

    The way I do it is :
    Make a movie clip that you want to display that the movie is loading.
    Put it in 3 keyframes
    on the first keyframe no actions
    2nd keyframe actions:
    ifFrameLoaded (your last frame of the entire movie) {
    gotoAndPlay (your first frame of the actual movie);
    }
    This checks if the last frame of your movie is loaded, if it is, it will go to the frame that you chose on the gotoandplay, if it hasn't finished loading it will go to the next frame (3rd)

    3rd frame actions:
    A simple go to and play to the first frame, because you know it hasn't finished loading.

    Hope that you understood and that worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center