dcsimg
A Flash Developer Resource Site

Page 1 of 2 12 LastLast
Results 1 to 20 of 31

Thread: those blurry pixel fonts

  1. #1
    Senior Member
    Join Date
    Feb 2002
    Posts
    122
    i realize this question is posted often, however i looked through previous threads and can't find a solution. MY PIXEL FONTS LOOK BLURRY IN FLASH! i'm using different fonts, for example one of them being hooge 05_57. i am sticking to the guide lines i.e 8pt, even x and y position, left aligned, all caps...YET it's blurry. in a previous post one reply to the same problem was "Select text options and make the field of text dynamic. Then press that little button down at the left hand corner of the box which means embed. Looks like this [ ]. Press that button. It works" however that didnt work with me either. ANYONE know the solution??????
    Thanks you!

  2. #2
    Senior Member
    Join Date
    Aug 2001
    Posts
    114
    try to do a remove transform on your textfield. are you viewing your exported movie in the flash player?

  3. #3
    Senior Member
    Join Date
    Feb 2002
    Posts
    122
    it seems to be working now, no i hadnt exported it as movie yet, didnt realize that would make a difference, i was just doing 'test movie'
    THANK YOU VERY MUCH

  4. #4
    Senior Member
    Join Date
    Aug 2001
    Posts
    114
    no problem...

  5. #5
    Senior Member
    Join Date
    Feb 2002
    Posts
    122
    i just realized however, that it only works when i do remover transform, and what that does is put the text field on a fractional x, y but then when i export the movie it looks fine in the flash player. how can this be even though it's not in an even x,y position???
    thank you for all your help.

  6. #6
    Senior Member
    Join Date
    Aug 2001
    Posts
    114
    are you making sure you are aligning everything towards the upper left corner?

  7. #7
    Senior Member
    Join Date
    Feb 2002
    Posts
    122
    how exactly do i make sure of that, besides align:left ?

  8. #8
    Senior Member
    Join Date
    Feb 2002
    Posts
    122
    ....and will it always look blurry when you view it in 'test movie' i.e. do u always have to export to .swf to view it correctly.
    thx

  9. #9
    Senior Member
    Join Date
    Aug 2001
    Posts
    114
    go into the inlfo panel and tick the little upper left square . and yes - it will almost 100 % of the time look blurry when you test movie. export to be sure. press f12 to preview in browser. that's the quickest way.
    hope this helps

  10. #10
    Senior Member
    Join Date
    Feb 2002
    Posts
    122
    you been a great help, thank you! i have another question, nothing to do with fonts, but since you're such a prompt replier, i thought i'd ask ....how do i make sure my movie/site is always centered regardless of the browser window size (the site is 650x500 if that makes a difference).
    thank AGAIN
    p.s. i love you're site! and thanks for the fonts that one can download there.

  11. #11
    Senior Member
    Join Date
    Aug 2001
    Posts
    114
    try this:

    <table width="100%" height="100%" cellpadding="0" cellspacing="0" border="0" cols="1">
    <tr><td align="center" valign="middle"> PUT YOUR STUFF IN HERE </td></tr></table>

  12. #12

    Remove the blur

    If you use Pixel fonts in a flash movie, you should always set Flash player to LOW quality, and they will be sharp as a button.

  13. #13
    Senior Member
    Join Date
    Feb 2002
    Posts
    122
    what about the rest of the things in the movie? then they will become low in quality as well?

    thank you cosenza for all your help!!

  14. #14
    As long as you don't mix pixel fonts and normal fonts, and don't have strokes on vector fills then it will be fine. Images look better without being aliased too. My current flash file uses low quality and is extremely sharp.

  15. #15
    Senior Member
    Join Date
    Feb 2002
    Posts
    122

    yes..me again :)

    them pixel fonts are driving me mad ....i have my site, yes...in it i have different textfields, yes...some textfields look fine others are BLURRY...NOOOO!!! i've stuck to all the above replies, expect the last one which i dont quite get ->"don't have strokes on vector fills". plus, i DO have a normal font on the site too so the antialias won't work out.

    ANYthing else...as discriptive as possible pleeeaze??
    greatly appreciated!


  16. #16
    Junior Member
    Join Date
    Feb 2002
    Posts
    3

    BSUC....great advice

    Uniqh, I'd say BSUC's advice to set the movie quality to LOW is the best advice I've seen. You can bypass most of the other advice you've gotten and use this if you are simply using text in your movie. Setting quality to low is an easy way to make the pixel fonts sharp and it's worked wonders for me and my site's appearance. Thanks to BSUC and good luck to you, uniqh!

  17. #17

    uniqh..check out my post.

    I posted a new thread...instead of replying by mistake..so I'll post this reply so you get a notification !
    I think it'll help you.
    "use device fonts" in the text options window seemed to be the magic solution to make my hooge 05_55 clear at 8pt.
    -jon-

  18. #18
    Senior Member
    Join Date
    Aug 2001
    Posts
    114
    it should not be nececarry to put the movie quality to low. but - if that makes it work it's ok.

    if you choose use devicefonts then those who do not have the font you use installed will get a nother font displayed on their computer.

  19. #19

    device fonts...

    Yah..you're right..sorry...just figured that out..

  20. #20
    Senior Member
    Join Date
    Feb 2002
    Posts
    122
    thank you all so much for trying to help me out!!

    Still.....

    setting the quality to low DOES make all the text fields sharp!!! however then there excist the same problem as setting it to antialias->the rest of the graphics/fonts etc. on the site become bad quality.
    Is there perhaps a way to apply the low quality/antialias only to the textfields?? Or how come it's working for the rest of you?
    what am i missing here???

    One thing i'm noticing (maybe it gives a clue) is that when I move the text fields that DO appear sharp with the mouse anywhere i want to, they will always position themselves onto whole x,y positions (which is good) where as the blurry text fields will move over ALL pixels (12.5, 12.6, 12.7 etc.) Eventhough i have set the same parameters for all of them.

    I love pixel fonts, but as long as i can't figure out how to use them correctly......

    THANX so much again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center