My system is Mac OS 9.2.2, G4

I just bought a Flash 5, right after I installed, updated to 5.0a, and entered all my serial number, The software crashed right away (this happens everytime I reinstall). And also everytime I try to open the Action window, it crashes and gives me the same error which is a type 2 error has occurred. This happened when I had Mac OS 9.1, and I updated it to 9.2.1 (still crash), then 9.2.2 (still crash)

I did try the following:
1) Restart the software with all extension off
2) Trash the preference
3) Zap the PRAM
4) Allocate more prefered memory to 50000k
5) Turn off the virtual memory
6) Rebuild my desktop
7) Run a virus scan
8) Trash the software and flash prefrence and Reinstall with all extensions off
9) Start my system from Mac OS 9 CD (can't even open a software and with error saying "missing Winsock Lib) then turning off all extension except Winsock Lib and still no luck
10) Remove the whole Preference folder from system folder, then restart Flash

Please please help
Do u guys have any problem at all runing your Flash 5.0a on G4 OS 9.x

Is it just my OS or the software not compatible with Mac OS 9.x

Despeartely need help