dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: looping question...

  1. #1
    Junior Member
    Join Date
    Mar 2002
    Posts
    10
    I have made a movie in mx and want it to loop consistantly. The problem is, it seems there is a gap in the loop, like there are extra frames being looped. Here is the example: http://www.phyre.net

    See how the fire is fading out? In the timeline the fire effect is constant flames, not fading out. But the published swf has the fading issue like on my home page (only page as of yet). Please help.

  2. #2
    Junior Member
    Join Date
    Jan 2002
    Posts
    12
    It play's so fast it is hard to tell, but I think I see the problem. It looks like your last frame doesn't match your first frame, so you get a choppy transition. It's like fading a box from red to blue and looping it. At some point you would see the box jump from blue to red when it went back to the first frame. What you would need to do is fade it from red to blue to red to make it loop smoothly.

    Lets say your ani is 20 frames, what you will need to do is create a mirror image of frames 1-20 and add it to the end of your ani. So basically create the same animation backwards and add it to the end. This should realls smoothe things out.

  3. #3
    Junior Member
    Join Date
    Mar 2002
    Posts
    10
    Cool thanks I will try that!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center