dcsimg
A Flash Developer Resource Site

Results 1 to 2 of 2

Thread: having trouble with bsaics

  1. #1
    Senior Member
    Join Date
    May 2002
    Location
    Seattle WA
    Posts
    171

    having problems with basics

    i have three buttons that are movie clips. when rolled over a cover slides over on roll out cover shuts , actual buton is alpha 0
    -----------------------------------------------
    on (rollOver) {
    gotoAndPlay(2);
    _root.rollpicts.text = "WEBSITES";
    }
    on (rollOut) {
    gotoAndPlay(7);
    _root.rollpicts.text = _;
    }
    on (release) {
    gotoAndPlay("websites");
    }
    ------------------------------------------------
    the problem is it doesn't go to frame label "websites" on the main time line, it seems like it just goes to frame one of the buttons movie clip. i have also tried
    ---------------
    gotoAndPlay("mainmovie" , "websites");
    ---------------
    the f1 help says i'm doing everything right
    is there something stupid i'm missing.
    i am now stuck.


  2. #2
    Senior Member
    Join Date
    May 2001
    Location
    Peoria, Arizona
    Posts
    1,889
    _root.gotoAndPlay(); >> tells the main timeline what to do

    movieclip.gotoAndPlay(); >> tells the movieclip from your curent place what to do

    _root.movieclip.gotoAndPlay(); >> tells a movieclip in the main timeline what to do

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center