dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: loadMovieNum problems

Hybrid View

  1. #1
    Junior Member
    Join Date
    May 2002
    Posts
    11
    I'm having a problem loading an external swf. I wanted to use it as a transition. I have this: (just to give idea, syntax not correct)

    on (release)
    loadmovienum "clapboard.swf,2)
    gotoandplay (scene 2, 1)

    So I want clapboard to play up front while the change is made from scene one to scene two. That way, clapboard.swf blocks the changing background. But for some reason, once the button is clicked, it goes to scene two, and then loads the movie. What am i doing wrong?



  2. #2
    Member
    Join Date
    Apr 2001
    Posts
    92
    just try changing sequence

    on (release)
    gotoandplay (scene 2, 1)
    loadmovienum "clapboard.swf,2)

  3. #3
    Junior Member
    Join Date
    May 2002
    Posts
    11
    I tried that but it's a no go. Scene2 always loads before the movie. I want the movie to load first. Hmmmm.

  4. #4
    Member
    Join Date
    Jun 2002
    Location
    Germany
    Posts
    37
    Well, I think the Movie is loading while Flash jumps to scene2.
    So, before the movie is completly loaded, you are in scene2.
    Try to handle this with ifframesloaded or just with a break

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center