dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: bug in flash MX?

  1. #1
    Member
    Join Date
    Jun 2002
    Location
    deventer, the netherlands
    Posts
    38
    My problem:

    I want to disable the buttons/movieclips that lay below (imported) movieclips. I tried the .enabled-command. This doesn't work in flash MX, exept when exported as a flash5 movie. Is this a bug or am I doing something wrong or is there an other way to disable movieclips and buttons?

    thanx for helping out,

    Mark

  2. #2
    Developer
    Join Date
    Sep 2001
    Location
    The Bluegrass State Will Flash For Food
    Posts
    3,789
    what do you mean by lay below? do you mean that they are covered by a movieclip or they're inside the movieclip? what code are you using...?

  3. #3
    Member
    Join Date
    Jun 2002
    Location
    deventer, the netherlands
    Posts
    38
    I'll be more specific: movieclip A contains buttons with certain actions. movieclip B is placed in the same scene in a higher layer. An action in movieclip B should disable the buttons in movieclip A and when B is unloaded, the buttons in A have to be enabled again.

    The code I use in movieclip B:
    _root.movieclipA.enabled = false;

    When exported as Flash5-movie this works, but as a Flash6-movie nothing happens.

    strrrrange...?

  4. #4
    Member
    Join Date
    Nov 2001
    Posts
    96
    If the movieclips you want to disable are underneath other movieclips then visibility shouldn`t be an issue, so try this...

    "Movie clips that are not visible (_visible property set to false) are disabled."

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center