dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: Where is my script failing......????

  1. #1
    Senior Member
    Join Date
    Aug 2000
    Location
    Desert Southwest
    Posts
    367
    Hi ---

    I am hoping someone can assist with my problem. I have struggled with this for the last day and know that I am close to getting it done, but I desparately need some guidance.

    1)I have a movie clip (1st) that has a number of text boxes --which basically is a contact us form
    2)That form then sends the data to an asp page
    3)The ASP page processes the data and sends off an email with the relevant data
    4)While the data is being processed (by ASP) another movie clip (2nd) runs stating that the email is being sent
    5)Once the email is sent ---the ASP page is supposed to send back a variable informing the movie that is was successful.....the 2nd movie clip should then stop.

    Step 5 is where the process is failing. The email gets sent but I can not propertly get the ASP page to communicate with the Flash Object.

    I have uploaded the FLA if anyone wouldn't mind taking a look at it and providing some feedback.

    http://www.digitalsaguaro.com/contact.fla

    Thanks for any and all assistance.

    Cheers.
    SDL

  2. #2
    Senior Member
    Join Date
    Nov 2000
    Location
    Allentown PA
    Posts
    350
    Step 4.5
    make the asp page reply with something like:
    responce.write "success=yes" (or however your sending info to flash)
    then have your step 4 movie clip cover 2 frames.
    on the second frame have :

    if (success == "yes") {
    gotoAndPlay([Whatever]);
    } else {
    gotoAndPlay([the previous frame number]);
    }


    Frequent-C
    http://www.Freq-Fest.com

  3. #3
    Senior Member
    Join Date
    Aug 2000
    Location
    Desert Southwest
    Posts
    367
    Originally posted by Frequentc
    Step 4.5.....
    Thanks for the reply.

    Does it matter if my loadVariablesNum is in the 1st MC and sending the retrieved variables from the ASP page to level 0?

  4. #4
    Senior Member
    Join Date
    Nov 2000
    Location
    Allentown PA
    Posts
    350
    Originally posted by sleblang
    Thanks for the reply.

    Does it matter if my loadVariablesNum is in the 1st MC and sending the retrieved variables from the ASP page to level 0?
    nope, just change it to:
    if (_root.success == "yes") {
    gotoAndPlay([Whatever]);
    } else {
    gotoAndPlay([the previous frame number]);
    }

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center