dcsimg
A Flash Developer Resource Site

Results 1 to 12 of 12

Thread: move is different in browser

  1. #1
    Junior Member
    Join Date
    Mar 2002
    Posts
    29

    Post

    Hi all

    I need some help with this here's what I do:

    1) I create a new movie
    2) Insert some text
    3) Click modify ->Break apart
    4) Click modify ->Distribute to layers
    5) Apply key frames and tweening to each
    6) Only apply a CW rotation to each
    7) Press enter and movie runs perfect!

    8) Press f12-crtl to watch in browser and the movie is totally different!


    What am I doing wrong?

  2. #2
    iguanagirl32 mraspiller's Avatar
    Join Date
    Jul 2002
    Posts
    817
    what is different about it?

  3. #3
    Junior Member
    Join Date
    Mar 2002
    Posts
    29
    Originally posted by mraspiller
    what is different about it?
    It doesnt rotate CW it slides in left -> right

  4. #4
    Senior Member
    Join Date
    Jun 2000
    Location
    London
    Posts
    293
    what happens when u test it with CTRL-ENTER

    ***or CTRL-RETURN***

    ^^^^^^MAC USER^^^^^^^

  5. #5
    Junior Member
    Join Date
    Mar 2002
    Posts
    29

    Ctrl-Enter

    Works just like browser slides in from left to right loses the CW effect.

  6. #6
    Junior Member
    Join Date
    Mar 2002
    Posts
    29
    I also just did this: 1) I create a new movie
    2) Insert some text
    5) Apply 25 frames to movie add keyframe at 1 and 25 and add tweening
    6) Only apply a CW rotation to the text
    7) Press enter and movie runs perfect!

    8) Press F12-crtl or Crtl-Enter to watch and the movie is totally different!

  7. #7
    Senior Member
    Join Date
    Jun 2000
    Location
    London
    Posts
    293

    symbol.....

    Now we take it that the text u inserted has been made into a symbol F8 ????

    graphic or movie clip will do.

  8. #8
    Junior Member
    Join Date
    Mar 2002
    Posts
    29

    Re: symbol.....

    yes

    it has been made into a symbol.

  9. #9
    Senior Member
    Join Date
    Jun 2000
    Location
    London
    Posts
    293

    very strange

    in a new doc:
    1. write test on stage - STATIC TEXT
    2. F8 convert to symbol.
    3. click on frame 25, press F6
    4. click on rotate panel enter 90
    5. right(control) click in between 2 keyframes and select motion tween.
    6. test movie

  10. #10
    Junior Member
    Join Date
    Mar 2002
    Posts
    29

    Re: very strange

    Still no good dont know whats going on with it.

  11. #11
    Senior Member
    Join Date
    Sep 2002
    Posts
    265
    rather than trying to run through the checklist of what you did or didn't do right, you ought to post the FLA files for us to take a peek at. It would have been resolved in the 2nd post rather than the 10th.

    Hitting "ENTER" on a movie has little to do with CTRL-ENTER (testing the actual exported flick)...

    maybe your export settings are goofy, your player out of whack, etc. I had problems with certain flash 5 movies working with the flash MX player if I saved the flash 5 clips as flash mx clips... I had problems with things I did on my PC not loading up on a mac via my webserver but working fine on the PC... etc. the possibilities are endless.

    In theory:
    "1) I create a new movie
    2) Insert some text
    3) Click modify ->Break apart
    4) Click modify ->Distribute to layers
    5) Apply key frames and tweening to each
    6) Only apply a CW rotation to each
    7) Press enter and movie runs perfect!

    8) Press f12-crtl to watch in browser and the movie is totally different!"

    should not have any problem.
    you did omit the step 4.5 where you converted each letter to a movie clip...
    1. new movie
    2. type ABC
    3. break apart
    4. dist to layers
    5. make A movie clip
    6. make B movie clip
    7. make C movie clip
    8. shift select frame 10 in each layer
    9. hit F6 to insert keyframe
    10. shift select frame 5 in each layer
    11. select MOTION TWEEN
    12. select rotate CW
    13. enter to test
    14. ctrl-enter to test

    works fine for me

  12. #12
    Senior Member
    Join Date
    Sep 2002
    Posts
    265
    k i grabbed the movie in question and yes, this was happening. the problem was solved in one of two ways:

    1. the font was _serif... when I double clicked each movie clip symbol in the library, the font had not been broken apart. This doesn't matter, but as soon as I broke apart _serif, it worked.

    2. rather than breaking apart the font, I simply changed the font to one that I had... this made it work.

    avoid _serif, i guess?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center