dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: FS Command Problem

  1. #1
    Junior Member
    Join Date
    Jan 2002
    Posts
    13
    I've been working with Swish 2 and flash player 5 and there were no problems with the FS Command Exec, but when I changed to Flash player 6 that command don't work anymore. What can I do?

    Thank you
    Raldia

  2. #2
    Senior Member Lys12's Avatar
    Join Date
    Feb 2001
    Location
    Munich, Germany
    Posts
    5,237
    hi,

    first of all you should update to the newest build of flash player 6, there were several problems with early versions!

    also if you're using fscommand to e.g. launch programs, you'll now have to place the programs in a folder named "fscommand". so the setup that worked previously ( swf and exe in the same folder, fscommand exec, argument program.exe) will now have to look like this:
    swf and folder named "fscommand" are within the same folder, fscommand exec, argument fscommand/program.exe

    does this help?

  3. #3
    Junior Member
    Join Date
    Jan 2002
    Posts
    13
    Thank you for your answer, but it didn't work. I tried exactly what you said and nothing.

  4. #4
    Flashkit historian Frets's Avatar
    Join Date
    Oct 2000
    Location
    flashkit
    Posts
    8,797
    I've found that you don't need the folder name in the arguement.
    However the rest of Jack's statement is true.

    The file to be opened must be inside a subfolder of the folder where the projector file is located

    /folder/projector.exe
    /folder/fscommand/program.exe


    Also don't open the swf from test in player in swish.
    What happens is that the file is created in a temp folder and then creates the file path to linked objects

    ergo the original arguement program.exe
    becomes something like C:\my stuff/folder/fscommand/program.exe

    Instead save the swf then open it up with the flash player.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center