dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: geturl problem with XP

  1. #1
    Junior Member
    Join Date
    Nov 2000
    Posts
    16
    I have made a Flash projector that autoruns on CDROM.
    There are some buttons that link to movie clips using:

    on (release) {
    getURL("video/movie1.avi");
    }

    This works for most machines I have tested on (Win98, Win2K, WinXP).

    On one machine tho, it gives an error of:

    Cannot find file ..D|/video/movie.avi....

    this happens also to other links (eg. .jpg)

    But...if the CD contents are copied to the harddrive, it works fine.

    I'm thinking it could be an isolated problem (hopefully!), because it works fine for other XP systems.

    Any help/insight appreciated.

  2. #2
    ReMember jennyj's Avatar
    Join Date
    Feb 2003
    Location
    UK
    Posts
    549
    Sorry, can't help you, but I am having exactly the same problem, everything works on all the systems I have tested, but my client reports exactly your problem(using XP, IE6), combination that I have tested!

    Hope someone has an answer!

    JennyJ

  3. #3
    Tim (Super Moderator) Northcode's Avatar
    Join Date
    Dec 2000
    Location
    Whitehorse YT
    Posts
    3,766
    Over here there's a trick you can use (with one minor change) to get around this problem..

    drv = _url.substr(8,1);
    geturl(drv + ":\\video\\movie1.avi");

    drv is the drive letter of the CD or drive where the projector was started from, this lets you construct absolute paths to the location on the CD where the file lives.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center