dcsimg
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: Masks in Buttons?

  1. #1
    Junior Member
    Join Date
    Aug 2001
    Posts
    10
    Hi folks,

    Does anyone know of a limitation in flash 4 with using masks in buttons? I have a button that I have a mask in which is placed on the stage in one of my scenes. Within flash the mask works fine on the stage but when I publish the mask does not work in the SWF file.

    Any thoughts?

    Best regards

    Greg.

  2. #2
    Junior Member
    Join Date
    Sep 2001
    Posts
    2

    me too :(

    I'm on Flash 5 and I have the sane question... I don't see why it wouldn't work, but my masks are coming undone in preview/publish as well, If anyone wants to take a look at my .fla, I'd be happy to send it to them... HELP PLEASE!

  3. #3
    Junior Member
    Join Date
    Aug 2001
    Posts
    10
    Hi Shaftbond... since putting this original post up I found some info on macromedia's site under flash support... and sure enough if you do a search on button masks it will come up with an item that states flash doesn't support masks in buttons... a shame it works so nicely within the authoring enviro.

    gb.

  4. #4
    Have you tried Creating a movie clip that does the mask and then just place the movie in the button over state.

    Later

    JLE

  5. #5
    Junior Member
    Join Date
    Oct 2002
    Posts
    6
    wow talk about timing. i was just having this problem this morning. firehawk, your idea worked. i thought of your solution too, but i was trying to use a graphic as a mask instead of a movie clip. once i changed the behaviour of the graphic with masks to a movie clip, it worked great. in other words www and shaft, create the desired effect in a movie clip, then drag the movie clip into your button.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center