A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: AutoRun problems with Windows XP SP1

  1. #1
    Junior Member
    Join Date
    Jul 2001

    AutoRun problems with Windows XP SP1

    I created a flash presentation in Flash MX and I am running Windows XP with service pack 1 upgrade.

    I created my autorun.inf file and my presentation file name is "presentation.exe" (literally). My autorun.inf file reads as follows:


    Now, this works fine in every computer I've tried (Windows 98 through Windows 2000), except for mine which is running Windows XP Pro SP1.

    Now, question...On my macromedia mx cd there is an autorun.inf file, a autorun.exe file, and a "install macromedia studio mx.exe" file that has the Flash icon so I think it's a projector file. My question is: What is the autorun.exe file? It has the Windows icon and it seems to be some sort of file that launches the projector. I tried (unsuccessfully) to just put that autorun.exe file on my CD thinking maybe it would look for any old .exe file to run, but it must be written specifically for that projector filename.

    Thanks in advance. You guys always come through.


  2. #2
    Junior Member
    Join Date
    Jul 2001

    Problem Solved

    Well, I solved my own problem. Basically I learned two things about autorun.inf files. Number 1: you can't use spaces in the file name. I haven't tested it yet, but I think if you put a "%20" (no quotes) where the space in the filename appears, it will work...but don't hold me to that. It's best to just remove spaces in the filename and replace with underscores if you have to.

    Second thing. You can actually inadvertently disable your auto insertion notification is you aren't careful. In Windows XP, each time you put a CD in, it will ask you "What do you want to do?", and it will give you some options. I got tired of this prompt and selected "Take No Action", and leave me alone.

    My CD wouldn't autostart for certain CDs because of this...well, this is how you restore defaults. I hope this helps someone!

    1. Double click on the My Computer icon on your desktop until it opens.

    2. Then click once on your CD / DVD Rom Drive, it will become highlighted.

    3. Then click on the word File, which is contained in your top tool bar area.

    4. This will pull down a menu for you to now click on Properties.

    5. Then click on the Auto Play tab at the top of the screen.

    6. Notice how you can adjust settings for Music CDs, Music Files, Pictures, Video Files and Mixed Content.

    7. Now select one of these multimedia types by using the pull down arrow to the right with your mouse.

    8. Then for each multimedia type, use your mouse to encircle the Select an action to perform: option.

    9. To disable that multimedia type, click on the “Take no action” icon at the bottom of the screen.

    10. Now click on the Apply button at the bottom of the screen to save your changes.

    11. Continue in the above fashion for each multimedia type, choosing the Take no action option.

    12. And ensure that you also click on the Apply button at the bottom of the screen to save your changes.

    13. Once all options are set to your choosing, click on OK button to exit the CD Drive Properties window.

    14. Repeat the above procedure on any additional CD Rom Drives you have in your system.

    15. Note: If you feel you have made a mistake, you can click on the “Restore Defaults” icon at any time.

  3. #3
    good post, thanks! very useful

  4. #4
    Join Date
    Jan 2002
    Good god, XP is so helpful, it screws everything up.

  5. #5
    Senior Member Dead Rabbit's Avatar
    Join Date
    Oct 2002
    Back in Tampa FLA again - and happy!
    Read The Autorun Reference Guide for detailed instructions on Autorun, including how to test autorun from disk without burning CDs.

    In the Autorun.inf on that CD, it iummediately launches Autorun.exe, which is whatever application they want it to be. You could name your presentation Autorun.exe for example.

    Hope this helps!
    While changing my profile, I accidentally clicked the link that said
    "Add 'Dead Rabbit' to your Ignore List"
    so now I can't talk to myself anymore...

    The Repository -:- The Forum

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

HTML5 Development Center