dcsimg
A Flash Developer Resource Site

Results 1 to 6 of 6

Thread: does this little detection work?

  1. #1
    Junior Member
    Join Date
    Nov 2002
    Posts
    12

    does this little detection work?

    i've created a homepage using flash mx. there are some actions in the swf that can only be read by version 5 or 6 of the flashplayer. so i've made a little flash detection within the swf. there is a warning ("you have an earlier version than flashplayer 5...") and this warning is made invisible by the following script:

    _root.warning.alpha = 0

    now version 4 can't read this so the warning will be seen.
    when i exported the movie as flashplayer 4, the warning appeared. when i did it with version 5, it disappeared.

    but i actually must export it for flashplayer 5. if someone is using flashplayer 4 will he be able to see the warning? or doesn't even try the flasplayer 4 to play the movie?

    i can't test it myself cuz i havent any earlier versions on my computer and i didnt find any on the web...

    thanks
    tim


    ps: im sorry its hard for my to describe my problem because of my pathetic english knowledge... i hope you nevertheless understand it

  2. #2
    Running Plodding & Limping SpockBert's Avatar
    Join Date
    Jun 2002
    Location
    London
    Posts
    593
    I think that will be fine.

    Flash4 will attempt to play the movie, it will just ignore any actions it doesn't understand.

    ps. I think your english is very good

  3. #3
    Sleepy
    Join Date
    Apr 2001
    Location
    Tallahassee, FL
    Posts
    498
    Originally posted by SpockBert
    I think that will be fine.

    Flash4 will attempt to play the movie, it will just ignore any actions it doesn't understand.

    ps. I think your english is very good

    that is correct. It will ignore instructions that is does not understand. The only other choice it would have when it came to something it didn't understand would be to barf and die, and that is bad software design
    Uh...where's my underwear?

  4. #4
    Newbie Forever It Seems Dar's Avatar
    Join Date
    Aug 2002
    Location
    Columbus,OH
    Posts
    218
    I seen a tutorial for this

    http://www.actionscript.org/tutorial...on/index.shtml

    it will tell you if the plug-in is at least ver.5

    USING MX

  5. #5
    pablo cruisin' hanratty21's Avatar
    Join Date
    Mar 2002
    Location
    on the lam
    Posts
    2,275

    old flash player versions


  6. #6
    Junior Member
    Join Date
    Nov 2002
    Posts
    12

    thanx!

    thanks to y'all!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center