dcsimg
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: CGI Posting with Flash

  1. #1
    Junior Member
    Join Date
    Oct 2001
    Location
    Melbourne, Australia
    Posts
    19

    CGI Posting with Flash

    Hi everyone!
    I'm having a major headache with a little piece of code in FlashMX

    Basically, I'm trying to use Flash to submit an email form via a pre-written CGI script. I cannot alter or write new CGI scripts as this would require more money to the people who provide the service.

    Now.. I have checked the example HTML form code, which is simply:
    <FORM METHOD="POST" ACTION="http://mailgate.server-mail.com/cgi-bin/mailgate">
    <input type=hidden name="recipient" value="sales@acme.com">
    <input type=hidden name="subject" value="Enter Subject">
    <input type=hidden name="redirect" value="http://www.acme.com/feedback.htm">
    Your Email address: <input type=text name="email"><BR>
    Your Full Name: <input type=text name="realname"><BR>
    Tell me what you think of me?
    <TEXTAREA NAME= "comments" ROWS=3 COLS=50>Type Here</TEXTAREA>
    <INPUT TYPE="SUBMIT" VALUE="Send Comments">
    </FORM>
    and this works without any problems. To test things, out in Flash, I made a very simple movie, with one button that contained the following script:
    on (release) {

    recipient="avalidemailwasused@here.com";
    subject="hello";
    comments="Hi There!";

    getURL("http://mailgate.server-mail.com/cgi-bin/mailgate",0,"POST");
    }
    however, when I run it, the "mailgate" server says "You must supply a recipient in order to use this gateway." - now I did give it a 'recipient' value, so does anyone know why this isn't working? I've used Flash with ASP before and not had any trouble. Could the problem lie with the "mailgate" client?

    Any thoughts would be appreciated.

    - Frustrated Cerious.

  2. #2
    Junior Member
    Join Date
    Oct 2001
    Location
    Melbourne, Australia
    Posts
    19
    Or failing to know why this wasn't working, does anyone know of another server I could use to send mail from a form?

    thx,
    Cerious

  3. #3
    Registered User
    Join Date
    Feb 2001
    Posts
    13,044
    Hi,

    would you mind to post the url to your test movie? [If it does not have an url because you test in the flash environment, maybe it is not really POSTing variables in test mode]

    Musicman

  4. #4
    Junior Member
    Join Date
    Oct 2001
    Location
    Melbourne, Australia
    Posts
    19
    Thanks MusicMan.... I'm pretty sure it's definately posting, but here's the .FLA just in case - maybe this will help.

    - Cerious
    Attached Files Attached Files

  5. #5
    Registered User
    Join Date
    Feb 2001
    Posts
    13,044
    Hi,

    I was looking to test the movie in real life ... loading the movie from your website, filling in some rubbish, and actually submitting it

    Musicman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center