dcsimg
A Flash Developer Resource Site

Page 1 of 2 12 LastLast
Results 1 to 20 of 38

Thread: Help me please!!!!!

  1. #1
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178

    Help me please!!!!!

    I'm trying to load a .txt file filled with a bunch of band names. Some of the names are links and some aren't. Everything loads and you can see it in the flash movie, but the formatting is not the way I want it and I can't seem to fix it. I don't want a double space between each band name. It also won't scroll to the end of the page like it is supposed to. It keeps stopping at a band called "Kevin & the Kasualtys". Can someone look at the attached file and see if you can tell me why it isn't working? Any help is greatly appreciated.

    Thanks.
    Attached Files Attached Files
    delstrange

  2. #2
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Text in the text file should be in one continuous line without any CRs. Each new line in the text file will double up in the textfield.

    As for your file cuting off, it's because of the "&" in the band's name, and which is a reserved character in Flash to indicate the start of a new variable. Use %26, instead of the "&" in the text file.

  3. #3
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    Oldnewbie, thank you very much. You are very wise.
    I would have never known about the %26 thing. Thanks again.
    delstrange

  4. #4
    Senior Member
    Join Date
    Feb 2001
    Location
    On the fifth floor.
    Posts
    1,202
    I think it will be better.
    And BTW, you shouldn't write "Kevin & the Kasualtys" because "&" is break for variables. It should be "Kevin %26 the Kasualtys".
    Heh! This Oldnewbie as usual is faster then me.
    Attached Files Attached Files

  5. #5
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    Thanks to both of you. But now I'm having some problems with some of the other files I'm dealing with that use the same thing to read the txt file. I have it set to full justification on the text box and everything looks the way it should when I test it locally. As soon as I put it on the server and view it some of the lines indent. I don't know why it does this on the server. There aren't any extra spaces either. Like I said it looks fine locally. You can see what I mean if you go to www.delstrange.com/2bluemoon and then click on staff and view any of the bios.

    Thanks again.
    delstrange

  6. #6
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Full justification doesn't work in dynamic textfields! Simple as that!

  7. #7
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    I've tried it in left justification also. And once again, it looks the way it should locally but not on the server over the net.

    I just don't understand why it looks right one way and not another way.
    delstrange

  8. #8
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    A link? Is this html formated text?

  9. #9
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    Yes this is html formatted text. Like I said it looks exactly the way it should locally when testing it in flash, but as soon as I put it on the server, the text indents on certain parts. I know there aren't any extra spaces that would make it look that way, because I tried getting rid of the space but then of course it just made it one long word. So I don't know.

    Thanks.
    delstrange

  10. #10
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Are you changing font sizes within the text?

  11. #11
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    No, some of the words are all caps to stand out more though.
    delstrange

  12. #12
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Give me a link! And one to the text file!

  13. #13
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    The site is www.delstrange.com/2bluemoon then go to staff and click on Paul or any of the names. The link to the text file is http://delstrange.com/cgi-bin/plugin...fBios/bill.txt

    Although I haven't changed anything in the file once I put it on the server. It is the exact same thing that I have sent in the attached zip file.


    Thanks again for your help.
    Attached Files Attached Files
    delstrange

  14. #14
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    Any luck oldnewbie? I figure if anybody knows it'll be you.

    Thanks
    delstrange

  15. #15
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Can you make the font you used on this available?

  16. #16
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    i have attached the font in a zip file.
    Attached Files Attached Files
    delstrange

  17. #17
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Seems to be a combination of the font you used and the width of your textfield... Only workaround I have found if you don't want to change either (even then sometimes you do get curious offsets), is to remove the space between the two words where this occurs, and force a linebreak (<br>) instead.

    A bit tedious but it seems to work.

    Thus I remember correcting 5 such offsets in your Paul's text file and it seems to now work fine:

    http://odin.prohosting.com/~oldnew/f...sting/paul.swf

    Attached in the new text file, if you want to check it.
    Attached Files Attached Files

  18. #18
    Senior Member
    Join Date
    Nov 2000
    Location
    Columbus OH
    Posts
    178
    Thanks oldnewbie for all of your help. I replaced the text file with the one you did and put it on the server, but it still looked the same. I saw your .fla and it looks exactly the same way mine does when I test it in flash. I don't get it.

    Anyway, I forced the line break like you said and it worked. But it really sux, because now that's just something else I'll need to teach the people I'm building the site for if they want to make changes to the bios themselves in case they don't look right.

    Thanks again for your help.
    Last edited by delstrange; 02-27-2003 at 06:40 PM.
    delstrange

  19. #19
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Sorry I attached the wrong text file. I updated the one on my server and then simply attached the one you had sent me, rather than the update one! Here it is, this one should work!
    Attached Files Attached Files

  20. #20
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Can't win them all! But at least it works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center