dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: Multiple external text .txt files in different swf files

  1. #1
    Junior Member
    Join Date
    Jun 2002
    Posts
    17

    Multiple external text .txt files in different swf files

    I'm trying to have several external files (txt or html) attached to a several swf flash files, loading in different levels of one main movie, for easy updating.

    Example is: loadVariablesNum("ext-track.txt", 0);
    This I can do, partly working.

    Say you click the button for "about" that loads that flash file (in a layer), it fails to load in the relevant external file (the movie loads just not the external text file).

    When you open up the "about.swf" on its own, it loads up the external file no problem. It just fails to do it when I am loading it from the main swf movie file that then loads this in a layer.

    I can get all the text files working by putting in all the loadVariable parts in the main movie but I need them put into their relevant swf movies.

    Does that make sense?

    How do you correct, something to do with layers or targetting? I'm sure it'll be easy for you guys, Actionscript ain't my thing.

    Thanks.

  2. #2
    pablo cruisin' hanratty21's Avatar
    Join Date
    Mar 2002
    Location
    on the lam
    Posts
    2,275
    Are you sure that they are not loading? Or are the dynamic text fields not displaying? You should check first to see if they are loaded...use a few trace commands.

    Also - just as an FYI, whenever I load external text, I always load it to level_0 or _root, -- this way, I don't have to worry about (what I think) the problem that you are running into is.

    My guess is that you are not targetting the variables within the flash movie on the right level. Try checking out the loading process with trace commands first. Then work backwards.

    RH

  3. #3
    Junior Member
    Join Date
    Jun 2002
    Posts
    17
    Originally posted by hanratty21
    Are you sure that they are not loading? Or are the dynamic text fields not displaying? You should check first to see if they are loaded...use a few trace commands.Try checking out the loading process with trace commands first. Then work backwards.
    RH
    Okay, thanks. Done that and it was just the text not displaying. Yes, not targetting the variables within the flash movie on the right level.

    Now fixed and all working. Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center