dcsimg
A Flash Developer Resource Site

Results 1 to 10 of 10

Thread: external swf problem

Hybrid View

  1. #1
    Vox = Voice Vox98's Avatar
    Join Date
    Mar 2001
    Posts
    879

    external swf problem

    Hello all, I havent been around flash in a while and just recently picked up a small project and funny thing is, a few basic things have escaped me!! Problem I am having is with loaded MC's into MC containers. I have done this many times before and have never seemed to have a problem with it until now. When I have my container for my extMC in my main movie and I go and play the main movie it loads fine but the problem I am having is the loaded MC shows outside the dimensions of the container. I have made sure that the container for the MC and the actual ext swf are the exact same size yet this keeps happening. What am I doing wrong?

    thank you

  2. #2
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    What's the actual code you're using?
    Or better attach your .flas.

  3. #3
    Vox = Voice Vox98's Avatar
    Join Date
    Mar 2001
    Posts
    879
    Thanx Oldnewbie, my file sizes are to big for FK, but the code I am using is:

    Code:
    loadMovie("news.swf", "newsholder");

  4. #4
    Vox = Voice Vox98's Avatar
    Join Date
    Mar 2001
    Posts
    879
    Still looking for help with this problem

  5. #5
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    A link at least!

    Couldn't you zip up the files and if the package is still too large upload it to your server and provide a link to download it from there?

  6. #6
    Vox = Voice Vox98's Avatar
    Join Date
    Mar 2001
    Posts
    879
    Haven't used my server in a while but here

  7. #7
    Vox = Voice Vox98's Avatar
    Join Date
    Mar 2001
    Posts
    879
    bump

  8. #8
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    I guess this is what you're looking for...

    Masked the .swf, although you did publicly post it!

    Ticker text is a little blurry, but the font must be embedded, because news.swf must be masked...

    http://odin.prohosting.com/~oldnew/interface.swf

  9. #9
    Vox = Voice Vox98's Avatar
    Join Date
    Mar 2001
    Posts
    879
    Yes Oldnewbie, thats it! How did u do that? Im still having a problem with the loaded MC's showing outside of the targeted holder. You didn't mask it did u? I dont ever remember doing anything like that before. Maybe u were just talking about how u just targeted the problem area for viewing.

  10. #10
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    No! I did mask the whole movie, just not to show the rest of it, in case you didn't want to.
    But you also have to mask that holder clip, and for that the font must be embedded in the ticker tape component you used, that's why it's a little blurry, because you were not embedding it originally.

    Also had to correct your text file because you were using an "&" which is reserved in Flash to indicate the start of another variable.

    I can send you the files, if you PM me an address, because I can't attach them here.

    See what you make and understand of the changes I've made, then you can ask me further questions through this forum.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center