dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: LoadMovie basics

  1. #1
    Junior Member
    Join Date
    Sep 2003
    Location
    SF
    Posts
    4

    LoadMovie basics

    I am doing the simplest task! I created a movie clip instance with the name Move Holder. I created a action of LoadMovie on the Key Frame that holds the instance. The Movie I want top load there is called SlidingTimeLine.swf

    What am I doing wrong.

    Here are the errors:


    Scene=History Time-line, Layer=Layer 16, Frame=32: Line 1: ')' or ',' expected
    loadMovie (SlidingTimeLine.swf, Move Holder);

    Error opening URL "file:///C|/Documents%20and%20Settings/Lindsay/My%20Documents/Personel%20CD/Flash%20Project/SlidingTimeLine"

  2. #2
    FK's Geezer Mod Ask The Geezer's Avatar
    Join Date
    Jul 2002
    Location
    Out In The Pasture
    Posts
    20,490
    No spaces allowed, quote the string in parenthesis and write it this way, it's more dependable:

    _root.Move_Holder.loadMovie("SlidingTimeLine.swf") ;

  3. #3
    Junior Member
    Join Date
    Sep 2003
    Location
    SF
    Posts
    4

    Continuing Problem

    Well I was able to get the error messages to end and I loadded the swf into the movie.

    But... The swf is only showing the first frames of the 1st scene and none of the functionality is working?

    I created a shaired Lib file with all of the assets linked and published that swf.

    I opened the ultimate movie and dropped those symbols, buttons and movie clips into that files stage via Open as shaired Lib (then deleted them from the stage).

    The ultimate file's Lib shows all of the required assets now in the file (looks good to me).

    When I test the movie (or publish it) the scene where I want the loadmovie to show, only shows the graphic content of the first frames, no sub-movie clips in that swf or functionality?

    Please HHEEELLLLP This is so close to working I cant stand it!

  4. #4
    FK's Geezer Mod Ask The Geezer's Avatar
    Join Date
    Jul 2002
    Location
    Out In The Pasture
    Posts
    20,490
    Sorry, can't help with the shared libraries. Never used them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center