dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: Horrible masking bug

  1. #1
    Senior Member
    Join Date
    Apr 2001
    Posts
    175

    Horrible masking bug

    I have one movieclip masking another. The masking movieclip that contains the mask is empty until I use draw commands to determine what it should contain. When I test the program and it gets to this part, I get an 'illegal operation' error from the flash player, which promptly closes. Is this a known bug? Are there ways around it?

  2. #2
    Senior Member
    Join Date
    Nov 2001
    Location
    Houston TX
    Posts
    563
    Can't tell what you are doing without the FLA.

    www.tobymack.com
    www.e4net.com
    Best regards
    Toby Mack

    For the best and funniest Audio Blog on the Internet come visit:

    http://feeds.feedburner.com/Fla****UpBlog

  3. #3
    Senior Member
    Join Date
    Apr 2001
    Posts
    175
    Good idea. http://www.flecko.net/files/temp/maskbug.fla - don't run it straight out of Flash, export it and run it in the standalone player, because it will crash instantly.

    Edit: I've found something out - it only seems to crash in player version 7.0 r19. In version 6.0 r79 it does not crash, but it does not mask, either (it just doesn't show up). If I draw stuff into the mask layer beforehand in flash then that will mask, but any draw commands I execute on it do nothing.
    Last edited by Flecko; 12-30-2003 at 05:33 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center