dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: button rollover not working with Mac browsers

  1. #1
    Senior Member ceglia's Avatar
    Join Date
    Jan 2003
    Location
    Los Angeles
    Posts
    262

    button rollover not working with Mac browsers

    for some reason, the music on/off button on this site i built isn't working on Macs. works perfectly on PCs.

    i've tried it on Safari and the latest version of Mac IE, and the on/off button does not respond.

    here's the link to the site....

    www.carlottamanaigo.com

    the music only plays on the HIGH BANDWIDTH version. you'll see the music on/off button on the bottom right.

    i've also attached the music button code below. the code appears in the first frame.

    PHP Code:
    mySoundtrack = new Sound();
    mySoundtrack.loadSound("soundtrack.mp3"true);
    mySoundtrack.onSoundComplete = function() {
        
    mySoundtrack.start();
    };

    // initialize musicVar and balloonVar.
    musicVar "on";
    balloonVar false;

    //define show/hide balloon functions.
    function hideBalloon() {
        
    musicMC.musicInfo.gotoAndPlay("hide");
        
    clearIntervalmyInterval );
        
    balloonVar false;
    }
    function 
    showBalloon() {
        
    musicMC.musicInfo.gotoAndPlay("show");
        
    myInterval setInterval(hideBalloon4000);
    }

    // define music button functions.
    musicMC.musicButton.onRollOver = function() {
        if (
    balloonVar == false) {
            
    balloonVar true;
            
    showBalloon();
        }
    };
    musicMC.musicButton.onRelease = function() {
        if (
    musicVar == "on") {
            
    musicVar "off";
            
    musicMC.gotoAndStop("off");
            
    musicMC.headphones.gotoAndStop(1);
            
    mySoundtrack.setVolume(0);
        } else {
            
    musicVar "on";
            
    musicMC.gotoAndStop("on");
            
    musicMC.headphones.play();
            
    mySoundtrack.setVolume(100);
        }
    }; 
    any help would be greatly appreciated!

  2. #2
    Senior Member SJT's Avatar
    Join Date
    Mar 2000
    Location
    London, UK
    Posts
    2,563
    Works fine for me in Safari, check you have the latest player installed on the machine you're testing with.
    Sam



  3. #3
    Senior Member ceglia's Avatar
    Join Date
    Jan 2003
    Location
    Los Angeles
    Posts
    262
    thanks SJT. when i first read you're reply, i was like, c'mon, you think i'd miss something like that??

    but sure enough, you hit the nail right on the head!!

    i have no idea what version of the flash plug-in i was running, but it was clearly something below 6. i was testing the site on my old powerbook G3, and i just ASSUMED it had all the latest plug-ins installed. wrong. i downloaded version 7 and it works perfectly. i'm sure 6, if it was still obtainable, would have worked as well.

    sorry for the trouble. i feel like an idiot now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center