dcsimg
A Flash Developer Resource Site

Results 1 to 9 of 9

Thread: page Transitions

  1. #1
    I am a Man.
    Join Date
    Feb 2003
    Location
    My Shanty
    Posts
    150

    page Transitions

    My intros and outros are built into each of my flash movies(.swfs) and I am trying to make transitions.

    In my buttons I am using this script:
    Code:
    on(release){
    _level0.next_movie = "services.swf"; //variable is set...
    _level0.container.play(); // plays the outro of the current movie...
    }
    Once a button is pressed, only a variable is set, rather than having the requested movie loaded up immediately. On the last frame of each of these external movies, is where I actually load the next movie in the same container...

    I use this on the last frame of each movie:
    Code:
    stop();
    _level0.container.loadMovie(_level0.next_movie);
    My problem is the pages never load when I release the buttons, why?
    R.P.H

  2. #2
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    That code looks familiar!

  3. #3
    I am a Man.
    Join Date
    Feb 2003
    Location
    My Shanty
    Posts
    150
    It looks familiar because you helped me with it awhile ago. I am trying now to implement it into my stuff. There is a problem with it though, when you click on a button on the initial page the files don't load. What I tried to do is load the movie when it enters the frame but then it affects how my movie looks and functions.

    This is what I am trying to figure out. How can I initially call up one these movies without having to load one of them from a keyframe. Once one works they all work.
    R.P.H

  4. #4
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Guess you'll have to make your .fla(s?) available! Zipped up and in MX only format.

  5. #5
    I am a Man.
    Join Date
    Feb 2003
    Location
    My Shanty
    Posts
    150
    the .fla files are to large to post. But I am including a cheap prototype.
    Attached Files Attached Files
    R.P.H

  6. #6
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    No code in the main movie? Are you're expecting me to write the whole thing?

  7. #7
    I am a Man.
    Join Date
    Feb 2003
    Location
    My Shanty
    Posts
    150
    Sorry forgot to included the button code. Here it is.
    Attached Files Attached Files
    R.P.H

  8. #8
    Banned
    Join Date
    Apr 2001
    Location
    Montréal, Québec.
    Posts
    25,397
    Well obviously, there must be someting in the container movie clip to start with, to start the ball rolling!
    Otherwise, playing an empty container, that doesn't have code to load the next movie, won't obviously work!
    Added a home.swf loaded in the container clip at the beginning, then everything works fine.
    Last edited by oldnewbie; 12-06-2004 at 01:00 AM.

  9. #9
    I am a Man.
    Join Date
    Feb 2003
    Location
    My Shanty
    Posts
    150
    Hey thanks a lot. I just made an empty home.swf and loaded that to get the ball rolling. It works like a charm now.
    R.P.H

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center