dcsimg
A Flash Developer Resource Site

Results 1 to 10 of 10

Thread: IE 6.0 - View Source Glitch

  1. #1
    Senior Member ::bluemoth::'s Avatar
    Join Date
    Jun 2001
    Posts
    521

    IE 6.0 - View Source Glitch

    Not sure where to ask this, but this seemed the most appropriate place.

    I've recently found out that, when I placed a notepad shortcut on my Windows XP desktop, that View Source in Internet Explorer 6 wouldn't work.

    Having removed the notepad shortcut, it works. Only now, when I move the cursor over the view source menu item, it takes about 3-4 seconds before I can click it (almost as if the menu item freezes).

    Anybody else had viewsource problems, and know how to remedy this? I've tried numerous things I've found using a google search, but nothing about this particular glitch.

  2. #2
    Senior Member RUSHVision's Avatar
    Join Date
    Dec 2000
    Location
    Pacific Northwest
    Posts
    5,441
    I've experienced something similar using IE6 with WindowsME. For some reason I usually have to right-click and select 'View Souce' twice before it will kick in and open it up in Notepad. It hasn't always been that way, it just started happening one day. Since I can eventually get it to work I haven't knocked myself out looking for a fix.

    If anyone has any information about this behavior I would appreciate it as well.
    mrush


    > .. _ .: Join the FK ARENA!:..:RUSHVision vs. JWin:. _ .. <
    ..:: "Why aren't the lockout programs working?!?...Release the monkey!" ::..

  3. #3
    Senior Member
    Join Date
    Apr 2001
    Posts
    1,660
    I've had some troubles with viewsource too, it's a buggy thing in IE 6.0

    The issue was I had too many files cached in my 'temporary internet files'.
    Once I emptied the folder it started working right away. Now I'm cleaning about two times a week.

    g/l

  4. #4
    Senior Member ::bluemoth::'s Avatar
    Join Date
    Jun 2001
    Posts
    521
    Sense . . . I too tidy my temp directories on a regular basis, and even keep my internet explorer folder to about 100MB. It's even easier to keep on top of, when I configure all my applications to use a dedicated drive for temp files . . . all I do is clear that drive every week.

    As to right clicking for view source . . . that does work fine. Annoying though, as it isn't any use for viewing frameset parents or when a site disables it with javascript (though it can always be turned off with a few clicks). Speaking of javascript, I'm suprised someone hasn't developed a 3rd party plugin or browser, that allows you to switch javascript on/off at the click of a button. It would be really useful for web developers, and so would the ability to enable/disable plugins.

    Anyways, I have a feeling there is some buggy windows explaination at the root of the view source annoyance. I thought it may be that the internet explorer temp folder might be conflicting with the windows temp directory (as they're on the same drive), as it is a certified problem with Adobe Photoshop. However, even when choosing a dedicated drive for the internet explorer temp folder, I get the same problem.

    But like you say RUSHVision, I haven't knocked myself out looking for a fix . . . though I have tried re-installing IE, editing the registry, changing the view source program, keeping my temp internet explorer folder from over-caching . . . to no full recovery.

    Ah well . . .

  5. #5
    Senior Member Black_phoenix's Avatar
    Join Date
    Oct 2000
    Location
    Leeds, UK
    Posts
    2,194
    As Blue moth says its to do with the cache of the browser going over 80 meg, also another strange one i read is that if you have a shortcut to notepad on the desktop this also cause problems...

    my fix for it is to go into tools at the top then internet options and go to the advanced tab, 9th one up from the bottom "empty temporary internet files when browser is closed" that seems to solve it for me

    let us know if it works

    bp

  6. #6
    Senior Member ::bluemoth::'s Avatar
    Join Date
    Jun 2001
    Posts
    521
    This will probably suprise people.

    Having used the view source item like this for the past few days, I just found that (despite there are numerous causes of view source trouble) it is the view Encoding menu itme that is actually 'stalling'.

    Because it is the item above 'source' I never really gave it a thought at first, but when I selected view, them moved the cursor off the menu, and selected 'Source' it would click straight away. Soon as I rolled over 'Encoding' though . . . the item freezes. How bizarre.

    Now I'm off to find out what is causing this (as it does become annoying having to select the menu by purposfully avoiding the Encoding item). Perhaps finding a way to just disable the Encoding item from the menu completely would be the easiest thing.

    I've also selected 'Empty Temporary Internet Files folder when browser is closed' option too, as you suggested. Doesn't resolve the Encoding issue, but a very nice option to have. can't believe I'd never noticed it before Black_phoenix.

  7. #7
    Senior Member RUSHVision's Avatar
    Join Date
    Dec 2000
    Location
    Pacific Northwest
    Posts
    5,441
    Hmm...I'd say it's a more elusive Windows issue. It could have to do with the fact that I've got a shortcut to Notepad on my desktop, but I've had my browser set to empty the cache on exit every since I got this computer, so I don't know if that's the problem or not. It's possible that every time it has happened I had previously had my brower open long enough to accumulate a hefty cache and simply not noticed it, but I had it happen just today with a pretty clear cache.
    mrush


    > .. _ .: Join the FK ARENA!:..:RUSHVision vs. JWin:. _ .. <
    ..:: "Why aren't the lockout programs working?!?...Release the monkey!" ::..

  8. #8
    Senior Member ::bluemoth::'s Avatar
    Join Date
    Jun 2001
    Posts
    521
    I've always had a shortcut to notepad on my desktop, and it works on my other XP machine (no IE problems at all). I found it to be very bizarre though, for my new machine to disable source viewing in Internet Explorer though just because of it's presence on the desktop though (where on earth is the conflicting programming connection there Microsoft!?).

    No big loss to use Internet Explorer shortcut in quick launch instead though personally, but to find out that the Encoding menu item is messing around is quite annoying to say he least. I've never had problems with IE like this before, ever.

    This might help you though:

    http://www.mredkj.com/tutorials/tips_ie.html


    Can't seem to find anything to disable/un-stall my Encoding problem though.

  9. #9
    Senior Member RUSHVision's Avatar
    Join Date
    Dec 2000
    Location
    Pacific Northwest
    Posts
    5,441
    Ok, so I've renamed the shortcut to Notepad on my desktop and everything seems to be working fine so far, with Notepad coming up immediately after clicking 'View Source'. We'll see if it continues to function correctly.

    This might be a stupid question, but did you try deselecting 'Auto-Select' in the Encoding menu as mentioned in the article? I noticed that mine is set to 'Western European (Windows)' and I've never experienced any weird behavior with it.
    mrush


    > .. _ .: Join the FK ARENA!:..:RUSHVision vs. JWin:. _ .. <
    ..:: "Why aren't the lockout programs working?!?...Release the monkey!" ::..

  10. #10
    Senior Member ::bluemoth::'s Avatar
    Join Date
    Jun 2001
    Posts
    521
    Glad to hear you can view source properly now.

    As for myself, I've tried all available combinations in the Encoding menu. Even comparing the menu to my other machine, everything is the same.

    Strange.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center