dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: In need of great help debugging and explaning the creation of components

  1. #1
    Senior Member
    Join Date
    Aug 2001
    Location
    Philippines
    Posts
    515

    In need of great help debugging and explaning the creation of components

    Hey everyone,

    I tried making my first component several weeks ago, and I followed the instruction of Macromedia in their site.

    I understand (in the top level only) how it works, but what the tutorial didn't include was how the movieclip "xch" works in all this. That's why I can't get mine to work - I had to do many things differently from the sample so I ended up not knowing what to do with "xch".

    Posted are all the essential stuff.

    If you see the component_scroller.fla, in the components first action frame, you will see an import of actionscript (the component works as expected that way [vertical usage only, not horizontal, because I haven't implemented that yet], but when I comment out the #include and use code that I typed (which I thought was similar to the example of Macromedia), it didn't work.

    I would apprectiate any space time to help debug then explain to me what happened

    Thanks,
    Attached Files Attached Files
    Ramon Miguel M. Tayag

  2. #2
    Senior Member
    Join Date
    Aug 2001
    Location
    Philippines
    Posts
    515
    anyone help?
    Ramon Miguel M. Tayag

  3. #3
    Senior Member
    Join Date
    Aug 2001
    Location
    Philippines
    Posts
    515
    and for reference, the tutorial for creating components:

    http://www.macromedia.com/support/fl...reating_comps/
    Ramon Miguel M. Tayag

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center