dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: Projector work with getURL?

  1. #1
    Member
    Join Date
    Feb 2003
    Posts
    45

    Projector work with getURL?

    Hi,

    I am using the getURL command in the first frame of a movie to call a htm file. Within this htm file is an swf file. Some of the people using this will not have flashplayer installed, so I have saved this as a projector file.

    However, even when launched with the projector file, I can't view the swf on the htm page. Even with flash player running in the background!

    Is There any way to do this?

    Cheers

  2. #2
    Flashkit historian Frets's Avatar
    Join Date
    Oct 2000
    Location
    flashkit
    Posts
    8,797
    Hi,

    Is a flash blocker enabled on the users'
    browser?

    Check the path of the swf in your html code, make sure it's relative....
    everyone has different drive names
    for there cdrom.

    Chances are more likely that a
    user wouldn't have the ocx then
    the flash player.

    Can I ask why you are placing the swf
    in an html page as opposed to converting it to exe?
    Exe's are more reliable then swf's
    because swf's are dependent on the version of the plugin installed to the browser.

  3. #3
    Member
    Join Date
    Feb 2003
    Posts
    45
    Hi,

    Thanks for your reply.

    I will try and explain what im trying to do.

    I have created a CD-Rom in HTML. It consists of many pages of html text which runs in the browser. For each page there is a small swf file which is simply a button that plays a sound when it is clicked.

    It all works fine with flashplayer installed, but some of the users of the CD-Rom will not have flash player installed, therefore, so that they can use these buttons and hear the relevant sound, I created a projector file which simply uses getURL("index.htm"); to call the main page which is in the same dir..

    I presumed that because I had called the html file from the projector, that the embedded flash files would then work, but this is not the case.

    Hope this makes things clear,

    Im not aware of any flash blocker on my test system, and I have spoken to people who think it might be down to the version of flash im using? (MX)

    Any advice would be very helpful.

  4. #4
    Flashkit historian Frets's Avatar
    Join Date
    Oct 2000
    Location
    flashkit
    Posts
    8,797
    Hmm,

    what's the object embed code look like?

    What happens when you export to an
    earlier version of flash? swf4 for example.

    If it's a blocker or version issue you can add text to your code that will show when the swf isn't visible.

    Are you packing the files?
    If your using something like html to exe
    you will need to also pack the swf.

    If you are using something like
    SwishStudio you will need to list
    (add) the swf(s) to the dependencies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center