Sound Volume
A Flash Developer Resource Site

Results 1 to 13 of 13

Thread: Sound Volume

  1. #1
    a.k.a gltovar deadlock32's Avatar
    Join Date
    May 2001
    Location
    Naperville,IL
    Posts
    489

    Sound Volume

    Its been a while since i've been here.... I'll get straight to the point = ]

    setVolume command controls all the volume for every sound, this I know. what i forgot is the way to get around it, so the set volume command only affects one sound.

    i remember there was a way. thanks a lot guys.

    (using flash MX v6)

  2. #2
    Senior Member
    Join Date
    Apr 2002
    Posts
    682
    You need to associate your sound object with a specific movie clip. So, for example, if you have an empty movie clip on the _root timeline with an instance name of myMovie.

    mySound = new Sound(_root.myMovie)

    Then, you can change the properties of mySound, and it will only affect sound objects that are associated with that movie.

  3. #3
    a.k.a gltovar deadlock32's Avatar
    Join Date
    May 2001
    Location
    Naperville,IL
    Posts
    489
    its still controlling the other sounds.

    do the other sounds have to be called up though actions, because the other sound clips is controlling are just on the time line.

    also, its not playing the desired sound I want it to play... its not play any sound... = [

    code:

    onClipEvent(load){
    fuzz = new Sound(_root.DL32game.DL32fuz.actions);
    fuzz.attachSound("DL32Sound");
    fuzz.play(0,999);
    }
    onClipEvent(enterFrame){
    fuzz.setVolume(_parent._alpha);
    }


  4. #4
    Senior Member
    Join Date
    Apr 2002
    Posts
    682
    No, it shouldn't matter how the other sounds are called. If it's not working, the most common reason is that it cannot find the container movie. Check your path. I usually just put an empty movie on the root level so it's easy to target. If it's playing the wrong sound, I can only recommend that you check the linkage ID in your library.

  5. #5
    a.k.a gltovar deadlock32's Avatar
    Join Date
    May 2001
    Location
    Naperville,IL
    Posts
    489
    Almost gold


    I was calling up the wrong movieclip.

    But its still not playing the sound i want it to play. Its not playing anything

    the linkage is correct... isnt it?



    forgot... wont work even if the volume is set at 100 from start!
    Attached Images Attached Images
    Last edited by deadlock32; 10-12-2004 at 10:48 PM.

  6. #6
    Senior Member
    Join Date
    Apr 2002
    Posts
    682
    The syntax is right, but only you can check if the linkage is right. Right click the sound in your library and check it there.

  7. #7
    a.k.a gltovar deadlock32's Avatar
    Join Date
    May 2001
    Location
    Naperville,IL
    Posts
    489
    Take a look at the picture = ]

    i've checked the linkage... is there something im just missing entirley

  8. #8
    Senior Member
    Join Date
    Apr 2002
    Posts
    682
    Sorry, if there's supposed to be a photo there, I don't see one.

  9. #9
    a.k.a gltovar deadlock32's Avatar
    Join Date
    May 2001
    Location
    Naperville,IL
    Posts
    489
    really the attachment help.jpg isnt in one of my posts?

  10. #10
    Super Moderator
    Join Date
    Aug 2000
    Location
    Montréal
    Posts
    14,141
    fuzz.start(0,999);

    use 'start' instead of 'play' for sounds.

    gparis

  11. #11
    a.k.a gltovar deadlock32's Avatar
    Join Date
    May 2001
    Location
    Naperville,IL
    Posts
    489
    l luff you gparis.... you help me every time!

    hey Kennyb I bet looking at all that sound code every day, make you assume that play would work... I know you were tryin' = ]

  12. #12
    Super Moderator
    Join Date
    Aug 2000
    Location
    Montréal
    Posts
    14,141
    Oh well.. ffanks! All we need is luff, in the end

    gparis

  13. #13
    Senior Member
    Join Date
    Apr 2002
    Posts
    682
    I can't believe I over looked that. Nice catch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width


HTML5 Development Center

Poll by Flashkit.com