dcsimg
A Flash Developer Resource Site

Results 1 to 6 of 6

Thread: Animating a button on "mouse over" event

  1. #1
    Junior Member
    Join Date
    Nov 2004
    Posts
    3

    Animating a button on "mouse over" event

    I have created a menu and I would like to animate the buttons on a "mouse over" event. I have created a movie that is a variation of the moving spotlight example and added it to the list of elements. However, I cannot seem to both have the movie NOT play when the menu is loaded and have the movie play when the mouse over event occurs. If I disable the element at start-up, it does not play on mouse over. If I allow the movie to play at start-up, then it will also play on mouse over.

    Does any one know what I might be able to do to have the movie play only on the mouse over event, or suggest a different approach to achieve the same ends?

    Thanks,

    Ron

  2. #2
    Junior Member
    Join Date
    Oct 2004
    Posts
    27
    This might work: play the movie at the beginning, but don't show it. Give the show-command on mouse-over, the hide-command on mouse-out.

  3. #3
    Junior Member
    Join Date
    Nov 2002
    Location
    Chillburg City
    Posts
    22
    Hi there,

    You can also try to put the complete button animation under the Mouseover Tab in the button menu. It worked for me so far. Then you avoid the show and play issue. Make sure you didn't select "save as external file" or something.

  4. #4
    Junior Member
    Join Date
    Nov 2004
    Posts
    3
    Originally posted by Beautiful-Night
    This might work: play the movie at the beginning, but don't show it. Give the show-command on mouse-over, the hide-command on mouse-out.
    I guess I'll have to plead late-night fatigue. Your solution is simple and rather obvious. I could have sworn I tried that option, but when I wnet back and tried it this morning, I got the result I was looking for.

    Thanks

  5. #5
    Junior Member
    Join Date
    Nov 2004
    Posts
    3
    Originally posted by lout2000
    Hi there,

    You can also try to put the complete button animation under the Mouseover Tab in the button menu. It worked for me so far. Then you avoid the show and play issue. Make sure you didn't select "save as external file" or something.
    I have the solution I need, but I looked at yours and was uncertain how to implement it. I had thought of that as my first option, but under the meny section, I select mouse over, and I can add a new action which includes play element, but I can only play elements (AFAIK) that are already included as part of the main section. While I don't need it for the moment, I'd still like to know how you set yours up.

  6. #6
    Junior Member
    Join Date
    Oct 2004
    Posts
    27
    Quote: "I guess I'll have to plead late-night fatigue."

    Heh heh. Yep, that's when the obvious becomes enigmatic. Glad it's working now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center