dcsimg
A Flash Developer Resource Site

Results 1 to 8 of 8

Thread: Hello,

  1. #1
    Junior Member
    Join Date
    Dec 2004
    Location
    WA
    Posts
    5

    Hello,

    Hi, I have a website and i am trying to use mp3 sound, however when i
    try to play the movie i get this following message:
    "DirectSound cannot create buffer" Got any ideas?
    www.rageserver.tk

  2. #2
    Senior Member kusco's Avatar
    Join Date
    Nov 2001
    Posts
    681
    Hello Xea,

    Are you able to play MP3's normally without trouble?

    Make sure that you have the latest releases for DirectX (downloadable from Microsoft's web site) and that you have version 7 of of the Flash player from Macromedia. Finally, check that the correct drivers for your sound card have been installed and that Windows is using the correct drivers.

    If all of the above looks ok then try a different MP3 to rule out the possibility of a corrupt music file.

    If you haven't already solved this yourself then could you provide more details or even provide us with the movie file?
    Cheers,
    kusco
    (3DFA Support Team)

  3. #3
    Junior Member
    Join Date
    Dec 2004
    Location
    WA
    Posts
    5
    O sorry lol i was not clear on that. The mp3 music works by it self, but when i place the short cut into the 3d flash animation and try to play the movie then i get that message.

    I tryed to attach the mp3 as a file on this forums but it wont let me, so instead i uploaded it to my sebsite.
    http://www.angelfire.com/theforce/therage2/JINGLEBE.MP3
    It seems to work fine when i use just plain scrips, i just cant get it to work on the 3d flash animator..
    www.rageserver.tk

  4. #4
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244
    Something wrong with that mp3 file as I cannot get it to work in 3dfa Nor in any of my audio editing programs. It does play in Winamp however.

  5. #5
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244
    Ok fixed it. Must have been the way it was compressed. I got it to open in Audacity and resaved it.

    http://bretlanius.com/tmp/JINGLEBEfixed.mp3

  6. #6
    Junior Member
    Join Date
    Dec 2004
    Location
    WA
    Posts
    5

    oo wow!

    Omg! thanks you so much!!! These forums rule! and you rule as well!

    THank you thank you!!

    Any idea how i can prevent this problem next time or how to down load the Audacity that you used? thanks so much all
    www.rageserver.tk

  7. #7
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244
    I'm not sure what was wrong with the file myself but Audacity is a great FREEWARE program for audio editing

    http://audacity.sourceforge.net/

  8. #8
    var x:Number = 1; x /= 0;
    Join Date
    Dec 2004
    Posts
    549
    i have to agree with Xea, blanius is the best programmer iv ever met here in this forum

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center