dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: Embedding flash MX swf files into 3dfa.

  1. #1
    Junior Member
    Join Date
    Nov 2003
    Location
    Ann Arbor
    Posts
    26

    Embedding flash MX swf files into 3dfa.

    Hi all,
    I recently made an mp3 player in Flash MX using an online tutorial somewhere on the web. However, I wanted to put this player in a webpage that is entirely flash using 3dfa. When the player stands alone on a basic html page, it works just fine. But when I insert the mp3 player .swf object into 3dfa, and then export the site with it included, it doesn't work at all. The player interface shows up just fine, but it does not stream the music files. I've attached a copy of the music player and the xml playlist file (sorry, I'm not including the songs because they are big files). But when working correctly, the message box on the player should display "LOADING...", reguardless if the music files are there or not. So with my basic understanding, I'm thinking when the flash file is embedded within 3dfa, it does not stream the files.

    Any ideas or suggestions how to fix this?
    Btw, feel free to use or modify the player for yourself.

    Again, thanks for your help
    - Ian
    Attached Files Attached Files

  2. #2
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244
    I guessing you may have refered to _root somewhere in that player eh? If so you need to change that to the relevant level probably _parent if it's one level above. If you refer to _root the loaded movie will see the 3dfa generated movie as _root.
    Code:
    Yep took a peek in your code and lines like
    
    _root.createEmptyMovieClip('sound_mc', 1);
          _root.sound_mc.sound_obj = new Sound();
          _global.song_nr = random(songfile.length);
          _root.sound_mc.songStarter(songfile[song_nr], songname[song_nr]);
    you need to change all _root to _parent and it should work as a loaded swf
    Last edited by blanius; 08-07-2005 at 08:43 PM.

  3. #3
    Junior Member
    Join Date
    Nov 2003
    Location
    Ann Arbor
    Posts
    26
    EDIT: Actually I thought it worked, but now it doesn't. I changed all the _root to _parent, but now it seems like the 3dfa object which the player is embedded is now taking a really long time to load, and then when it does, the player dissapears. It can be seen for a brief second.
    Last edited by ifmuth; 08-07-2005 at 10:30 PM.

  4. #4
    KoolMoves Moderator blanius's Avatar
    Join Date
    Jul 2001
    Location
    Atlanta GA
    Posts
    5,244
    are you still embedding it? Don't put a empty child movie in your 3dfa and in your starting script put childmovie.loadMovie("muiscplayer.swf")

    Should work

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center