dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: Weird setInterval Problem

  1. #1

    Weird setInterval Problem

    Hi, I'm hoping someone has a thought on this... I am running ads on the front page of a site using the setInterval function in Flash 8.

    What's happening is that the rotater is runnning fine on 98% of the people's computers that view it, but there are a couple of people that are coming to me saying that they aren't seeing the ads... and only seeing a black square where the ads would have been.

    I've already ruled out the Flash 8 player. Everyone has it installed. For one person it is happening on a PC in IE and another on a MAC in Safari.

    Has anyone else seen this problem before? Any suggestions on things to try?

    Thanks in advance.

  2. #2
    Total Universe Mod jAQUAN's Avatar
    Join Date
    Jul 2000
    Location
    Honolulu
    Posts
    2,429
    Try switching to a use of the Time class and using an onEnterFrame to compare. It's a little more predictable and doesnt rely on the processor so much.

  3. #3
    Thanks jAQUAN, I'll try that. Do you think it might have to do with the person's processor?

    Thanks again.

  4. #4
    Total Universe Mod jAQUAN's Avatar
    Join Date
    Jul 2000
    Location
    Honolulu
    Posts
    2,429
    It really shouldn't matter. I can only think that it has something to with the viewers various security settings. Are you assigning the setInterval to a variable and using clearInterval at some moment.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center