dcsimg
A Flash Developer Resource Site

Results 1 to 6 of 6

Thread: gotoAndplay/Stop not working ne more

  1. #1
    Junior Member
    Join Date
    Sep 2005
    Posts
    5

    gotoAndplay/Stop not working ne more

    Hi,

    I created a movie with several nested movie clips. within these movies are stop actions to prevent the clips from playing at the wrong time. I created the gotoAndPlay/stop functions to play these clips at certain points of the animation. Now at first these actions worked smoothly and exactly as i wanted, however after several test movies, some of the gotoandplay/stop functions stoped working. Has ne 1 ever ecounterd this problem is there a way repair these actions without recreating the whole movie? i tried rewritting the scripts and still does not work.

    thx

  2. #2
    Senior Member
    Join Date
    Apr 2006
    Posts
    1,059
    gotoAndPlay(n) will gotothe frame and continue playing regardless of any stop() encountered on the target frame(not sure if this holds for subsequent frames)

    gotoAndStop will gotothe frame and( play until a stop is encountered?) or just gotothe frame and sit there cant remember(i just ripped a huge one)

  3. #3
    Senior Member
    Join Date
    Apr 2003
    Location
    MA
    Posts
    273
    Are you trying to play clips nested inside clips nested inside clips? Make ABSOLUTELY SURE that each one has it's own name. If you make a lot keyframes of the same object sometimes you can accidently delete it and put in a new one and it will lose its name. Click on your object and make sure it's named, and make SURE you have the names correct. Like Pie.crust.gotoAndStop("baked");

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Posts
    157

    Try my file

    can you try to use my file and try to link the MC buttons to the proper pages?

    If you can help me with this, that would be GREAT!
    Attached Files Attached Files
    Imagination is the creator of reality...

  5. #5
    Junior Member
    Join Date
    May 2008
    Posts
    1

    solving gotoAndPlay problem

    I had the following problem :

    either
    movie.gotoAndPlay(2)
    or
    movie.Play(2)

    would behave just the same as

    movie.gotoAndStop(2)
    or
    movie.Stop(2)

    even when I had a play() action on frame 2.

    The SOLUTION was :

    tellTarget(movie) {
    gotoAndPlay(2);
    }


    Hope this helps !

  6. #6
    Member
    Join Date
    Sep 2009
    Posts
    57

    resolved

    Here is the fixed file. Hope I am not TOO late
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center