dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: buttons wont work in a loaded swf..help please

  1. #1
    Member
    Join Date
    Nov 2004
    Posts
    79

    buttons wont work in a loaded swf..help please

    Hi all,

    im needing some help here,

    I have a main.swf,

    In this ' main.swf ' I am loading in various other swfs. For example in the 'main.swf ', if someone clicks on "profile" it loads in the 'profile.swf.'

    Here is my problem, in my loaded movie it has a simple menu. But the buttons wont work. Its fine when I view this particualr swf on its own, but when I load it into the main.swf they dont work.

    I have _root references on these buttons, so im thinking that because im loading this swf into my main.swf , the _root reference wont work.

    Is there any solution to this problem,

    I can provide more info if needed, please help, a commercial project depends on it.

  2. #2
    Junior Member
    Join Date
    Oct 2005
    Posts
    26
    If you have a button in profile.swf, and then load profile.swf into main.swf, "_root" refers to main.swf. If you use "_parent" in profile.swf instead, it should work.

  3. #3
    Member
    Join Date
    Nov 2004
    Posts
    79
    thanks for getting back matthijz ,

    I applied this piece of actionscript to the first frame of the profile.swf :

    _lockroot = true;

    and it worked !

    are you familiar with this work around? does it have certain disadvantages?

    once again thanks for the reply,

    suzi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center