dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: [RESOLVED] [F8] embedding for foreign languages-runtime and author time

  1. #1
    will i ever get it?
    Join Date
    Feb 2004
    Posts
    707

    [RESOLVED] [F8] embedding for foreign languages-runtime and author time

    oh oh- never thought i would have to ask this...i am doing a site in English, Italian , and French....this word: "Événements" has clearly proven i don't know how to embed fonts outside of Latin English...All i get is nements. Now, i have some text boxes on stage from authoring time, and some created at run time....what do i need to do to cover all bases for all text boxes...it's impossible to say which of the boxes will use words such as "Événements"

    or is the problem my xml??
    Code:
    <menubutton label="Services" sub0="Traductions" sub1="Événements" sub2="Faits sur commande">Service au francaise......you have to put the french things here.</menubutton>
    Last edited by mlecho; 09-27-2006 at 08:53 AM.

  2. #2
    will i ever get it?
    Join Date
    Feb 2004
    Posts
    707
    well...i am starting to think the xml is the culprit, based on this http://www.sephiroth.it/tutorials/fl.../specialChars/

    so, how do i encode these letters when they between quotes as attributes?

  3. #3
    will i ever get it?
    Join Date
    Feb 2004
    Posts
    707
    ok- that took a while, but if it works, then i guess it's right...here is what i came up with.:
    1- 1st line-> <?xml version="1.0" encoding="ISO-8859-1"?>- i think the encoding may have helped
    2-attributes in quotes will work fine, out of quotes need unicode assitanace. Thus between tag text must have &#201 if i want É....

    this became my friend- http://www.geocities.com/Athens/Acad...ph/fontset.htm
    Time for a beer

  4. #4
    Member
    Join Date
    May 2005
    Posts
    30
    Quote Originally Posted by mlecho
    ok- that took a while, but if it works, then i guess it's right...here is what i came up with.:
    1- 1st line-> <?xml version="1.0" encoding="ISO-8859-1"?>- i think the encoding may have helped
    2-attributes in quotes will work fine, out of quotes need unicode assitanace. Thus between tag text must have &#201 if i want É....

    this became my friend- http://www.geocities.com/Athens/Acad...ph/fontset.htm
    Time for a beer
    Hm.. Same problem here, and this solved some of it, but i cant get special chars as attribures to show...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center