dcsimg
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: stupid flash anti-alias bug!

  1. #1
    Total Universe Mod jAQUAN's Avatar
    Join Date
    Jul 2000
    Location
    Honolulu
    Posts
    2,429

    stupid flash anti-alias bug!

    This is so FK'ing annoying.
    If you create a text field and choose anything other than Use Device Fonts, flash will shift the baseline if opened on another OS.

    For instance, if you create a field on a mac, when you open/render the .fla on a PC, the baseline is shifted up about 4 pixels. It's the opposite when you go the other way. It's so frickin annoying to have to remember who created what and always having to use a certain comp to render .swfs.

    Anyone heard of this or know of a solution?

  2. #2
    Flashkit historian Frets's Avatar
    Join Date
    Oct 2000
    Location
    flashkit
    Posts
    8,797
    Hi,

    I'm not positive it is a mac related questions.

    Start here -
    http://board.flashkit.com/board/showthread.php?t=482646

    Checklist
    -Anchor set properly?
    -Anchor for all _parent mc's set properly?
    -Kerning off?
    -Margins off? (remember I'm a swishmax user text options are different for me)
    -No space before first text?
    -Text align left or right but not center or justified?
    -Are you using a monospaced font or pixel font?
    -Does your movie contain any place settings on the text which is different then the value of it's transform panel location. (keyframe tweens etc )
    -Is the font matched for point size below 14pts most common fonts have issues.
    -Can you (not a flash user or a mac user) convert the font to pixel sharp pixel smooth?


    Just a few idea's
    I understand mac flash has different properties when dealing with fonts then pc flash.
    and I haven't used flash in years (not since the release of swishmax)

    So I'll drop in mac forum they may have more knowledge specific to mac flash.

    Frets

  3. #3
    associate admedia's Avatar
    Join Date
    Oct 2001
    Location
    is
    Posts
    1,347
    Yea, I received a .fla from a client on a mac with specific fonts. I bought those fonts for the PC, opened the .fla and had to readjust. I don't know what that is or if it has more to do with just a completely different font file or variations in Flash platform.

  4. #4
    Total Universe Mod jAQUAN's Avatar
    Join Date
    Jul 2000
    Location
    Honolulu
    Posts
    2,429
    It's a known cross-platform issue
    http://chattyfig.figleaf.com/piperma...il/164688.html

    Thanks for the suggestions and the move Frets, but this isn't swishkit. You're starting to smell like spam.

  5. #5
    imagination through stupidity
    Join Date
    Apr 2001
    Location
    P3X-3113
    Posts
    1,238
    i've had the same problem, it is a cross-platform Flash IDE issue. I believe it also has todo with how the system handles fonts. I once got open type fonts from windows and when i installed them, their names changed completely along with a location shift. When you generate the SWF there isn't any font rendering issues that i've found.
    Nothing to see here, move along.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center