dcsimg
A Flash Developer Resource Site

Results 1 to 9 of 9

Thread: Getting videos to play in flash???

  1. #1
    Senior Member
    Join Date
    May 2004
    Posts
    322

    Unhappy Getting videos to play in flash???

    i want to create a help file for my project and probably the best thing i would like to add is videos. im wondering if anyone knows of any good video players in flash? so for instance i can add a few buttons to the source code and then these can link to the player which will play an avi/flv video? has anyone come across anything like this?

    (i have found tutorials on how to make one of these but unfortunately i dont have the time and will have to work on the 'proper' version after the first release of the project. in the meantime i am really looking for something which will not cost anything and will save me time...)

    thanks
    Everybody has a story to tell, what's yours? -- http://www.filmfiler.com

  2. #2
    Member
    Join Date
    Aug 2006
    Posts
    64

    Components

    Use the FLV playback component and just point to it with a button. Voila!!

  3. #3
    Moderator enpstudios's Avatar
    Join Date
    Jun 2001
    Location
    Tampa, Fl.
    Posts
    11,282
    Moved to flash video

  4. #4
    Senior Member
    Join Date
    May 2004
    Posts
    322
    Thanks everyone - I'm using a swf file with a FLV playback component on it. It reads an file from an xml file. It works fine when I'm testing in Flash IDE.

    However, when I attach the SWF as a movieclip in my main program I just get a blank screen, the (external) controls show however. Just wondering what could be the cause of this???

    Anyone have any ideas?
    Everybody has a story to tell, what's yours? -- http://www.filmfiler.com

  5. #5
    Senior Member
    Join Date
    Jan 2001
    Location
    London
    Posts
    361
    Ensure that the FLV playback component assets are placed in the main movie library, as well as in the loaded swf's library.

  6. #6
    Senior Member
    Join Date
    May 2004
    Posts
    322
    Strange things going on:

    - do you mean add the FLV component to the help library or the main movie which attaches help form?

    well it is already in the help library.

    weird thing is if i add it to the main movie i get some bizarre output. i have a scrolling thumbnail which is made up of some images which are loaded dynamically from xml. for some reason, if i add a FLV component to the library it changes those images into little FLV icons... very strange - im not even touching any of the code...

    what on earth could be going on ???
    Everybody has a story to tell, what's yours? -- http://www.filmfiler.com

  7. #7
    Member
    Join Date
    Aug 2006
    Posts
    64
    Are you loading the movie with Actionscript or through the component inspector?

  8. #8
    Senior Member
    Join Date
    Jan 2001
    Location
    London
    Posts
    361
    Yes i meant add the flv component to the main movie which attaches the help form. It sounds like the FLV component has assets which conflict with the scolling thumbnail. Is the previous problem resolved when you do this, disregarding the thumbnail images for a sec.

  9. #9
    Senior Member
    Join Date
    May 2004
    Posts
    322
    i'm loading the movie using AS - contentPath bit...

    i cant test whether the movie is loading because in order to do so i have to click on an item in the scrolling thumbnail and i cant do this... all i get are little icons in each place instead of the correct image being loaded... NONE of the help form code is even situated there - the thumbnail just loads stuff from xml...

    ive tested this further and it works ok in the flash ide, and also the swf file. however i am using zinc as a wrapper and it is not working in there so i guess it must be related to that software. i am checking on their forums but if anyone has come across this before please advise how you solved it;

    thanks!
    Everybody has a story to tell, what's yours? -- http://www.filmfiler.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center