dcsimg
A Flash Developer Resource Site

Results 1 to 2 of 2

Thread: SimpleButton - problem with movieclips in my display states

  1. #1
    Half Empty happinessSam's Avatar
    Join Date
    May 2003
    Location
    London
    Posts
    442

    SimpleButton - problem with movieclips in my display states

    I've never really bothered using simplebutton before, but I decided to give it a try for my current project. The different display states (downState, upState etc) are movieclips that are in the library with classes associated with them so I can easily change text colors and values of the labels.

    My problem is that I have a movieclip inside each that has a range of different icons to show. I can access this movieclip, and apply a color transform to it, but I can't get it to go to the correct frame because every time the simplebutton goes to a new state it makes the movieclip play.

    Is there a solution to this? Or do I need to do some arcane workaround, or switch the button to being a movieclip?

  2. #2
    Mod cancerinform's Avatar
    Join Date
    Mar 2002
    Location
    press the picture...
    Posts
    13,448
    Easiest solution in my opinion: switch the button to being a movieclip
    - The right of the People to create Flash movies shall not be infringed. -
    | www.Flashscript.biz | Flashscript Biz Classes/Components |

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center