dcsimg
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: Ignoring SVN folders

  1. #1
    Senior Member
    Join Date
    Jul 2001
    Posts
    164

    Ignoring SVN folders

    Here at the office we are starting to use Flex builder, but running into an odd issue. Our source files are (naturally) under source control, so in every directory there is an _svn folder. It is a hidden file in Windows.

    But, when we create a flash project these files show up. They are a bit annoying since there are so many and they are useless, but the real problem is at compile time. When we compile a project, Flex pulls the _svn folder into the bin folder. This creates two major errors.
    1) Subversion is now broken because files exist where they shouldn't.
    2) The Flex compiler gives us definition errors on those files.

    How can we get Flex to ignore the files???
    I have googled for hours without success. The FB2 preferences only allow you to ignore files, not folders, so this doesn't work. What really shocks me is not finding other people with this same issue. It seems like everyone using Flex would be using svn and having this same issue. maybe we are missing something simple?

    Thanks from our whole team here.

  2. #2
    Senior Member
    Join Date
    Sep 2005
    Location
    Detroit
    Posts
    193
    Key is to realize that it's not a Flex/Adobe problem but an Eclipse issue (Eclipse is the program Flex builder is built on.

    Can't say i have tried this with flex builder but here is a good article http://www-128.ibm.com/developerwork...cl-subversion/

    If that doesn't work with FB you can always install Flex on top of Eclipse with the Flex plug-in. your serial number will still work.
    While the music played you worked by candlelight
    Those san francisco nights
    You were the best in town
    Just by chance you crossed the diamond with the pearl
    You turned it on the world
    That’s when you turned the world around

  3. #3
    Senior Member
    Join Date
    Jul 2001
    Posts
    164
    In case anyone finds this thread in the future, here is the solution.

    - Right click on your project file in flex. Properties
    - Actionscript Compiler
    - Disable Copy non-embedded files to output directory


    (It is also nice to disable Generate HTML wrapper file so you can just open the swf directly when you compile.)

  4. #4
    Interactive Developer
    Join Date
    Oct 2007
    Location
    Saint Louis
    Posts
    10

    SVN for Flex Builder

    Have you tried installing the SVN component for Flex Builder? It's a nice plugin that allows you to update and push files to your SVN server all within the Flex Builder app....

    Here's a tutorial to set it up...
    http://tdotblog.info/?q=node/4

  5. #5
    Junior Member
    Join Date
    Jan 2004
    Posts
    2
    Using the ASP.NET version of svn which marks folders as _svn instead of .svn this "copy non embedded..." trick doesn't seem to work.

    Any thoughts?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center