dcsimg
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: [CS3] AS 2.0 [loadMovie is not working within a movie Clip

  1. #1
    Member
    Join Date
    Dec 2007
    Posts
    46

    [CS3] AS 2.0 [loadMovie is not working within a movie Clip

    Hello All

    loadMovie("mypic.jpg", this.targetPic); is not working in a nested movieclip.
    but when i add this code in the main movie's first frame it does work
    but when i add this code in a nested movie clip which is located in
    _root.pageGallery
    it doesnt not work

    i dont know why am i getting weird result
    Please help!

  2. #2
    http://www.in3d.eu Kostas Zotos's Avatar
    Join Date
    Jul 2007
    Location
    Athens - Greece
    Posts
    408
    Hi,

    Maybe try:

    loadMovie("mypic.jpg", _root.pageGallery.targetPic)

    Or:
    loadMovie("mypic.jpg", _root.targetPic)

    Depends where the "targetPic" is..

    This older post (regarding target paths, hierarchy etc..) maybe is still usefull: http://board.flashkit.com/board/showthread.php?t=765508
    Last edited by Kostas Zotos; 05-04-2008 at 01:00 PM.
    K. Zotos online portfolio: http://www.in3d.eu

  3. #3
    Member
    Join Date
    Dec 2007
    Posts
    46
    Thanks a lot
    i was giving the instanse name with long words like galleryTarget
    when i changed it to gTrgt, it started to work
    Thanks for the link

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center