dcsimg
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: tween weirdness

  1. #1
    flip-flopper scottPadgett's Avatar
    Join Date
    Jan 2005
    Location
    Boston
    Posts
    425

    tween weirdness

    would someone kindly look at the following link and refresh the page many times and observe how the behavior of the movie changes, refresh by refresh?

    i don't get it. the tween of the bit+polish logo is supposed to behave in an Elastic manner and sometimes it behaves correctly, but a lot of the time it just slides into place as though it were a Quadratic tween or other standard decelerating tween. or sometimes it's kind of Elastic but doesn't really behave according to the easing parameters...

    also, sometimes the movie doesn't even play completely. it will get hung half-way through the fade-in, before any buttons appear...

    does anyone know what could cause these abnormalities that are dependent on the specific loading of the page??

    i've got some loose guesses, but they don't really make any sense...


    it's at:

    http://wscottpadgett.com/bit10

    Many thanks.
    :: scott ::

  2. #2
    Senior Member
    Join Date
    Jan 2007
    Location
    Nottingham, England
    Posts
    263
    refreshed it loads - worked fine everytime for me? - sometimes the site itself didnt load though...

  3. #3
    flip-flopper scottPadgett's Avatar
    Join Date
    Jan 2005
    Location
    Boston
    Posts
    425
    hmm. interesting, it actually works for me in Firefox, but in Safari I still get this weird behavior. what browser did you try it in?

    i think you may be seeing the 'hanging up' when you say it didn't load at all. were you getting just a plain black screen when that happened?

    thanks.
    :: scott ::

  4. #4
    Senior Member
    Join Date
    Jan 2007
    Location
    Nottingham, England
    Posts
    263
    i use firefox browser and yeah, it was just a black screen i got sometimes.

  5. #5
    flip-flopper scottPadgett's Avatar
    Join Date
    Jan 2005
    Location
    Boston
    Posts
    425
    Does anyone else have any idea about how specific browser display would affect a movie's behavior?

    I have no idea what's going on. Particularly, about the black screen bit. Essentially, there are a bunch of Tweens that execute and the MOTION_FINISH listeners trigger the next thing that happens... So what must be happening in some way is that the Tweens simply don't execute sometimes. All of this motion is strictly Actionscripted and event-based.

    This is a new one to me. AS executing differently or jamming based on the browser???

    Any insight is greatly appreciated!!
    :: scott ::

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center