[CS3] Paint Bucket Issues
A Flash Developer Resource Site

Results 1 to 12 of 12

Thread: [CS3] Paint Bucket Issues

  1. #1
    Junior Member
    Join Date
    Jan 2009
    Posts
    5

    Question [CS3] Paint Bucket Issues



    Hey all, I'm a student currently trying to learn Flash CS3. However I've encountered a problem with the paint bucket. In my assignment I've created a simple rocket, each part with it's corresponding layer. Now I need to go back in and fill the body in a light gray color. I did so successfully with the nose cone. The problem now is that the bucket won't fill any other area no matter what I do, or which layer is selected.

    Where have I gone wrong?

  2. #2
    Senior Moment
    Join Date
    Mar 2004
    Location
    MN, USA
    Posts
    369
    Make sure your path is closed (zoom in close, use outline view). Sometimes it helps to actually select the shape you're trying to fill. Also, at the bottom of the tools panel, with the paint bucket selected there are options: don't close gaps, close small, medium, large gaps.

    Good luck!
    Victory belongs to "The Murray"!

  3. #3
    Junior Member
    Join Date
    Jan 2009
    Posts
    5
    Thanks ReNaeNae, I'll give that a shot and hope for the best!

  4. #4
    Junior Member
    Join Date
    Jan 2009
    Posts
    5

    Still not working...

    Well, unfortunately that didn't correct the problem. I looked very closely and there are no gaps on any of the layers, yet the paint bucket still won't fill the area selected.

  5. #5
    I Love India Nalini_v's Avatar
    Join Date
    Jun 2007
    Location
    Chennai
    Posts
    195
    Hi,

    just make sure that the layer is unlocked... and u have selected the filll big gap option avail at the bottom of the tool box

  6. #6
    Junior Member
    Join Date
    Jan 2009
    Posts
    5

    Unhappy

    ...I've done that too.

  7. #7
    Junior Member
    Join Date
    Feb 2009
    Posts
    1

    I think I've figured it out!

    Quote Originally Posted by dierdra_morgana
    ...I've done that too.
    Hi there, I was having the exact same problem and was going crazy trying to figure it out. Here's what worked for me, maybe it's the same problem you're having.

    In the Tools bar - that is typically the vertical bar on the left hand side of the screen (where you select paintbucket, pen, etc.) - after you have clicked on the pencil tool, near the bottom there is a button with a circle inside a square and when you hover, it says Object Mode. Check to make sure that this is OFF.

    My roommate's dog must have hit something to turn it on when she pawed at my keyboard last week and I could not figure out how to turn it off. Simple as that. Hope that helps!

  8. #8
    Junior Member
    Join Date
    Jan 2009
    Posts
    5
    That's a great point, but unfortunately I have tried that also. Another classmate of mine was having a similar problem: We sort of solved the problem by using the Pen tool, as opposed to the line tool. I don't know what was going on, but it was weird.

    Thanks for your input though!

  9. #9
    Junior Member
    Join Date
    Apr 2010
    Posts
    3

    Paint Bucket Issues sorted

    I have been having the same issues with paint bucket and after reading this post thread have finally sorted out the problem. Thank you so much. I am currently completing a cert IV Website Design and this is all new to me and I was struggling with this issue for the last 2 days. So once again thank you

  10. #10
    it would help if you send the .fla so we can analyze the problem, my guess is your objects do have gaps, but (u thought) u closed the gap by drawing on a different layer, this happens sometimes.
    free ecards site with flash animations and stuffs. visit, don't visit.. whatever.

  11. #11
    Registered User
    Join Date
    Mar 2012
    Posts
    1
    1)make sure all path have been closed...
    2)select the line that u want to fill in
    3)click Modify>Shape>Convert lines to fill

  12. #12
    Junior Member
    Join Date
    Jun 2013
    Posts
    1

    absolutely same problem

    I have exactly the same problem. I want to color a rocket drawing too and the bucket lets me fill only few parts of it. When i want to fill some other it just fills the whole background :/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width


HTML5 Development Center

Poll by Flashkit.com