dcsimg
A Flash Developer Resource Site

Results 1 to 8 of 8

Thread: audio won't play on first opening of browser

  1. #1
    Junior Member
    Join Date
    Apr 2008
    Posts
    21

    audio won't play on first opening of browser

    The audio won't start untill I refresh browser. I don't know very much about xml and nothing about php. I would send code for you to look at but don't know if you need to look at xml or php. There are many xml pages. Here is the link where I'm at so far. http://www.1jimage.com/ultimate-deploy/
    The template originally had 3 mp3 songs to choose from but I replaced them with one of my own. I did chang3 the titlel in one of the xml files and couldn't find any place else with the old names of old mp3's to change to the new name.
    jbechdel@comcast.net
    Attached Files Attached Files
    Last edited by offtheroad; 02-21-2009 at 01:09 PM.

  2. #2
    I know nothing.
    Join Date
    Feb 2008
    Posts
    315
    Started playing just fine fore me. Buffered for a bit. What browser are you using?

  3. #3
    Junior Member
    Join Date
    Apr 2008
    Posts
    21
    I'm using the latest Firefox & Safari. The audio file is 1.5 MB

  4. #4
    I know nothing.
    Join Date
    Feb 2008
    Posts
    315
    Try it in explorer and see if you have the same problems... Might be a setting in Firefox... 1.5 MB isn't too bad for a music file. Are you using MP3?

  5. #5
    Junior Member
    Join Date
    Apr 2008
    Posts
    21
    I'm on a mac and have a old version of Explorer 5.2 Yes it's an mp3 file/I got this response in another forum but no answer on how to solve it."you're probably calling the sound.play() before it's loaded enough to start." but they didn't tell me how to solve it.

  6. #6
    I know nothing.
    Join Date
    Feb 2008
    Posts
    315
    What version of Flash are you using and could you post your FLA?

  7. #7
    Junior Member
    Join Date
    Apr 2008
    Posts
    21

    Flash CS3

    I don't have the fla that was worked on. I lost contact with the person helping me and he won't send me the fla. I do have a virgin fla from the original template but I don't think that will reflect the template as it is now? Do you want the main.fla or the musicPlayer.fla?

  8. #8
    I know nothing.
    Join Date
    Feb 2008
    Posts
    315
    Please upload both, so we can take a look.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center