dcsimg
A Flash Developer Resource Site

Results 1 to 1 of 1

Thread: bufferTime, bufferLength, do not seem to work

  1. #1
    Senior Member
    Join Date
    Apr 2000
    Location
    Minneapolis
    Posts
    2,127

    bufferTime, bufferLength, do not seem to work

    DOH!!!
    ignore I was working on the wrong version of the file
    changed swf was not being loaded by main movie!!

    Hi,
    I have been testing various quality flv and f4v files. I was using a buffer of 4 to 6 seconds. It seemed fine.
    Then I set the bufferTime to 200 to check where an issue with stuttering on slower machines might be coming from. (Video is 201 seconds long)
    I noticed that the video just started playing as soon as a few seconds loaded. It is as if bufferTime does nothing?
    I tried to check bufferLength without any success, trace and textbox both do nothing.

    Any ideas? mark

    PHP Code:
    var videoToPlay:String;
    var 
    nc:NetConnection = new NetConnection();
    nc.connect(null);

    var 
    ns:NetStream = new NetStream(nc);
    ns.addEventListener(NetStatusEvent.NET_STATUSonStatus);
    ns.client this;
    video.attachNetStream(ns);
    ns.bufferTime 200;
    trace(ns.bufferLength);
    buffer_txt.text ns.bufferLength.toString(); 
    Last edited by mgason; 05-19-2009 at 01:29 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center