dcsimg
A Flash Developer Resource Site

Results 1 to 7 of 7

Thread: Hover on Roll Over issue

  1. #1
    Junior Member
    Join Date
    Jun 2009
    Posts
    9

    Hover on Roll Over issue

    Hi there..

    Could anyone please help me - I'm getting a flickering issue with my tool tip hovers. I've tried setting up the code in 2 different ways and I'm still getting the same thing!

    Each way seems to work fine if there's only one object, but when there's more than one and you start moving the mouse between the 2 this really annoying flickering keeps occurring? My file needs to have several objects which all overlap. I've tried altering the hit areas so that they don't actually touch - but no effect.

    I've also tried swapping ROLL_OVER for MOUSE_OVER and MOUSE_MOVE but all with no results..

    Please could anyone show me or point me in the right direction as to the best way to do something like this? I'm going crazy with it!

    I've attached the 2 flash files so you can see what I'm talking about..

    Thanks in advance for any help!!

  2. #2
    Junior Member
    Join Date
    Jun 2009
    Posts
    9

    sorry forgot to attach files..!

    sorry forgot to attach files..!
    Attached Files Attached Files

  3. #3
    Junior Member
    Join Date
    Jun 2009
    Posts
    9

    2nd file

    2nd file
    Attached Files Attached Files

  4. #4
    Senior Member
    Join Date
    Aug 2007
    Posts
    291
    I'm not sure what flickering issue you're talking about. Both files seem to be working okay for me. Can you describe it a little more specifically?

  5. #5
    Junior Member
    Join Date
    Jun 2009
    Posts
    9
    Hi - thanks for repying

    The flickering occurs when you move the mouse from the left apple straight over to right apple... Then when you continue to move it around on the right apple the hover keeps disappearing... It happens like that on both files

  6. #6
    Senior Member
    Join Date
    Aug 2007
    Posts
    291
    The only thing I saw was that, for some reason, the hit area wasn't registering on part of the apple. When you run the program, and you move around on the apple on the right side, you hit a point where the hit area doesn't seem to be triggering. If you keep your mouse over that area and keep moving it, the tooltip will stay gone. So, I don't think the flickering you're seeing is just when you roll over that part of the hit area. As for how to fix it, I'm not sure. I didn't see anything wrong with the way you'd done it.

  7. #7
    Junior Member
    Join Date
    Jun 2009
    Posts
    9
    I found the answer..! I just needed..

    tip_mc.mouseChildren = false;
    tip_mc.mouseEnabled = false;

    And that seems to have fixed it. It works on both files either inside or outside the function. Someone pointed me in the right direction on a different forum but thanks for taking the time to reply to my posts!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center