dcsimg
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: I want movie to NOT automatically play.

  1. #1
    Junior Member
    Join Date
    Nov 2002
    Posts
    3

    I want movie to NOT automatically play.

    A client gave me a video as an flv file. I imported it into Flash CS4 (mac) and created a skin with play controls and then using the publish setting created a swf and an html page. When I open the html page in Safari it works fine, but when I try it in Firefox (mac) the movie starts automatically, even though i chose 'Playback: Paused at start' option when creating HTML page. I want the movie to pause at the beginning. How do I fix this?

    http://benmclane.com/burnley1.html

    Thanks for your help.
    Michael

  2. #2
    Senior Member
    Join Date
    Jun 2008
    Posts
    549
    Is the flv embedded in the timeline or is it inside a movieclip?

  3. #3
    Junior Member
    Join Date
    Nov 2002
    Posts
    3
    thanks for the reply. uummm, well i'm not sure...be patient this is all new to me. sorry. ok, i'm not sure how to answer. as my previous post stated i opened flash, imported the flv and then created a swf file and an html file. all 3 are uploaded onto server, the flv, swf and html page. so, the flv file is still there but it streams thru the swf. does this make sense? sorry i'm not more knowledgable in flash. thanks again.

    michael

  4. #4
    Senior Member
    Join Date
    Apr 2002
    Posts
    2,849
    The paused at start option doesn't have anything to do with the video, I'm afraid. There are several different ways to play a video file in a .swf, but most likely, you can open the .fla, click on the video and you'll have something called component parameters. One of those will say "autoPlay". Make sure autoPlay is not checked.

  5. #5
    Junior Member
    Join Date
    Nov 2002
    Posts
    3
    thanks for the reply. i think that solved it. thank you!

    Quote Originally Posted by rdoyle720 View Post
    The paused at start option doesn't have anything to do with the video, I'm afraid. There are several different ways to play a video file in a .swf, but most likely, you can open the .fla, click on the video and you'll have something called component parameters. One of those will say "autoPlay". Make sure autoPlay is not checked.
    Last edited by cikemini; 01-19-2011 at 02:45 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center