Hi

I built a login flash page with AS3, it can call webservice to authenticate the username and password and return the result locally.

When I publish it to IIS 6 and run it in a browser, it can call web service but there is no response from the webservice.

I found http://www.codeproject.com/KB/aspnet...tRemoting.aspx and write the web.config file.

I tried to run:

C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Bin>soapsuds -url:http://[publicIP]/WebService/Service.asmx?wsdl -oaroxy.dll
Error: Invalid schema data., Attribute style not found. Line62,6) ElementName:
soap:binding.

How should I fix it?

The following is the AS3 code:

Code:
butLogin.addEventListener(MouseEvent.CLICK, doLogin);

function doLogin(event:MouseEvent) {
   UserName = txtUsername.text;
   Password = txtPassword.text;
   var ws = new WebService("http://[publicIP]/WebService/Service.asmx?wsdl");
   var op:Operation = new Operation(ws);
   prompt.text = "ws";   
   op.addEventListener(OperationEvent.COMPLETE, onResult);
   prompt.text = "OperationEvent.COMPLETE";
   op.addEventListener(OperationEvent.FAILED, onFault);

   op.CheckOperatorLogin(txtUsername.text,txtPassword.text);
   prompt.text = "call function";
}

   function onResult(e:OperationEvent):void {	   
	   for (var prop in e.data){
		   trace (e.data[prop]);
	   }
	   loginResult = int(e.data);
	   if (loginResult > 0){		   
	      gotoAndStop(2);
       } else {
	     stop();
       }
   }
   
   function onFault (e:OperationEvent):void {
	   trace (e.data);
   }
It can display call function and hanged.